Package: z-push / 2.4.5-2

Metadata

Package Version Patches format
z-push 2.4.5-2 3.0 (quilt)

Patch series

view the series file
Patch File delta Description
adapt path variable in migration tool.patch | (download)

tools/migrate-2.0.x-2.1.0.php | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 adapt path variable in migration tool


Set absolute path to z push in gab2contacts.patch | (download)

tools/gab2contacts/gab2contacts.php | 2 1 + 1 - 0 !
1 file changed, 1 insertion(+), 1 deletion(-)

 set absolute path to z-push in gab2contacts

Upstream does this with sed in the rules file, but using a patch is
cleaner imho.

apache2 config remove deprecated auth options.patch | (download)

config/apache2/z-push.conf | 9 1 + 8 - 0 !
1 file changed, 1 insertion(+), 8 deletions(-)

 apache2 config: remove deprecated auth options

This fixes two lintian warnings:
  W: z-push: apache2-deprecated-auth-config Order
  W: z-push: apache2-deprecated-auth-config Deny

Upstream uses a mechansim to detect the module 'mod_authz_core.c' and do
the access control in evaluation of this. This brings the advantage to
use the same Apache2 configuration file for all Apache2 versions no
matter if less or equal version 2.4.
In Debian we only have apache2 packages 2.2 in oldoldstable (wheezy)
right now. So we can ignore this kind of setup.