1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62
|
build: build-stamp
build-stamp:
dh_testdir
make doc-dvi
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
rm -rf compiled.docs
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
cp -r texmf debian/abntex/usr/share/
mv $(CURDIR)/debian/abntex/usr/share/texmf/doc $(CURDIR)/debian/abntex/usr/share/doc/abntex
mv $(CURDIR)/compiled.docs/*.dvi $(CURDIR)/debian/abntex/usr/share/doc/abntex
chown -R root.root $(CURDIR)/debian/abntex/usr/share/texmf/
chmod -R a-x+X $(CURDIR)/debian/abntex/usr/share/texmf/
binary-arch:
binary-indep: build install
dh_testdir
dh_testroot
dh_installdocs
dh_installchangelogs
dh_installtex
dh_link
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep
.PHONY: build clean binary-indep binary install configure
|