1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
include /usr/share/dpkg/architecture.mk
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
ifneq (,$(filter $(DEB_HOST_ARCH_OS),hurd kfreebsd))
TESTS_FLAKY = yes
endif
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- --bindir=/bin
override_dh_auto_test:
ifeq ($(TESTS_FLAKY),yes)
@echo "Notice: Running tests in flaky mode, errors will be ignored."
endif
$(if $(TESTS_FLAKY),-)dh_auto_test
override_dh_installchangelogs:
dh_installchangelogs doc/CHANGES
|