1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100
|
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
SCENES = default-scene dallas-scene
OBJECTS = inventory f16.obv f18.obv \
su30.obv mig23.obv mig25.obv mig29.obv \
kc135.obv c172.obv aim9.obv tracer.obv tower.obv \
f117.dxf il78.obv sa2.obv sa10.obv sa11.obv \
hangar.obv surface.obv telar1.obv \
acmlogo-unix.xwd object-map.txt munition-map.txt
SOUNDS = aconnon.au cannon.au crash.au engine.au gear_up.au \
gear_dn.au imarker.au missile.au \
mmarker.au omarker.au \
rwr.au screetch.au stall.au apglock.au
configure: configure-stamp
configure-stamp:
dh_testdir
CFLAGS="$(DEBCFLAGS)" ./configure --prefix=/usr
touch configure-stamp
build: build-arch build-indep
build-arch: configure-stamp build-stamp
build-indep: configure-stamp build-stamp
build-stamp:
dh_testdir
$(MAKE)
touch build-stamp
clean: configure-stamp
dh_testdir
dh_testroot
rm -f debian/icons/*.png
rm -f build-stamp configure-stamp
[ ! -f Makefile ] || $(MAKE) distclean
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
install -g root -m 755 -o root src/acm debian/acm/usr/games/acm
cd objects && install -g root -m 644 -o root \
$(SCENES) $(OBJECTS) $(SOUNDS) ../debian/acm/usr/share/games/acm
install -o root -g root -m 644 debian/icons/acm.xpm debian/acm/usr/share/pixmaps/acm.xpm
for r in 64x64 96x96 128x128 256x256; do uudecode -o debian/icons/acm-$${r}.png debian/icons/acm-$${r}.png.b64 ;done
for r in 64x64 96x96 128x128 256x256; do install -o root -g root -m 644 debian/icons/acm-$${r}.png debian/acm/usr/share/icons/hicolor/$${r}/apps/acm.png;done
install -o root -g root -m 644 debian/acm.desktop debian/acm/usr/share/applications
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installdocs acmdoc.rtf debian/acmdoc.ps README ACM-Bibliography
dh_installmenu
dh_installman src/acm.man
dh_installchangelogs
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
|