1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85
|
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ALIVERSION=3
configure:
build:
dh_testdir
gnatgcc -c -g -O2 cgi.adb ustrings.adb
build-arch: build
build-indep: build
clean:
dh_testdir
dh_testroot
rm -f *.o *.ali demo minimal search test_cookie test_send test_encode
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
cp -pf cgi.ads cgi.adb ustrings.ads ustrings.adb debian/adacgi$(ALIVERSION)/usr/share/ada/adainclude/adacgi
cp -pf cgi.o cgi.ali ustrings.o ustrings.ali debian/adacgi$(ALIVERSION)/usr/lib/ada/adalib/adacgi
cp -f debian/adacgi.gpr debian/adacgi$(ALIVERSION)/usr/share/ada/adainclude/adacgi.gpr
binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installdebconf
dh_installdocs
dh_installexamples debian/Makefile debian/examples.gpr demo.adb minimal.adb search.adb test_cookie.adb test_send.adb test_encode.adb
dh_installchangelogs
dh_link
dh_strip
dh_compress -X.adb -X.ads -Xmakefile
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
|