1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142
|
Author: Andreas Tille <tille@debian.org>
Last-Update: Sun, 01 Sep 2019 00:01:00 +0200
Bug-Debian: https://bugs.debian.org/936109
Description: Use 2to3 to convert from Python2 to Python3
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
# Copyright (c) 2010-2015, Daniel S. Standage and CONTRIBUTORS
#
@@ -6,7 +6,7 @@
# the 'LICENSE' file in the AEGeAn source code distribution or
# online at https://github.com/standage/AEGeAn/blob/master/LICENSE.
-from __future__ import print_function
+
import re
import sys
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
# Copyright (c) 2010-2015, Daniel S. Standage and CONTRIBUTORS
#
@@ -8,7 +8,7 @@
#
# Usage: check-gff3.py < annot.gff3
-from __future__ import print_function
+
import re
import sys
@@ -50,7 +50,7 @@
topleveltypes[values[2]] += 1
print('\n
-featuretypes = counts.keys()
+featuretypes = list(counts.keys())
featuretypes.sort()
for featuretype in featuretypes:
count = counts[featuretype]
@@ -60,7 +60,7 @@
print('%s (%lu total, %lu top-level)' % (featuretype, count, topcount))
print('\n
-childtypes = relationships.keys()
+childtypes = list(relationships.keys())
childtypes.sort()
for childtype in childtypes:
parenttypes = list(relationships[childtype].keys())
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
# Copyright (c) 2010-2015, Daniel S. Standage and CONTRIBUTORS
#
@@ -6,7 +6,7 @@
# the 'LICENSE' file in the AEGeAn source code distribution or
# online at https://github.com/standage/AEGeAn/blob/master/LICENSE.
-from __future__ import print_function
+
import argparse
import os
import re
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
# Copyright (c) 2010-2016, Daniel S. Standage and CONTRIBUTORS
#
@@ -6,7 +6,7 @@
# the 'LICENSE' file in the AEGeAn source code distribution or
# online at https://github.com/standage/AEGeAn/blob/master/LICENSE.
-from __future__ import print_function
+
import re
import sys
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
# Copyright (c) 2010-2015, Daniel S. Standage and CONTRIBUTORS
#
@@ -6,7 +6,7 @@
# the 'LICENSE' file in the AEGeAn source code distribution or
# online at https://github.com/standage/AEGeAn/blob/master/LICENSE.
-from __future__ import print_function
+
import argparse
import os
import re
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
# Copyright (c) 2010-2016, Daniel S. Standage and CONTRIBUTORS
#
@@ -6,7 +6,7 @@
# the 'LICENSE' file in the AEGeAn source code distribution or
# online at https://github.com/standage/AEGeAn/blob/master/LICENSE.
-from __future__ import print_function
+
import argparse
import re
import sys
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/bin/python3
# Copyright (c) 2010-2016, Daniel S. Standage and CONTRIBUTORS
#
@@ -6,7 +6,7 @@
# the 'LICENSE' file in the AEGeAn source code distribution or
# online at https://github.com/standage/AEGeAn/blob/master/LICENSE.
-from __future__ import print_function
+
import re
import subprocess
import sys
|