File: oldgcc.m4

package info (click to toggle)
alliance 5.0-20120515-6
  • links: PTS
  • area: main
  • in suites: jessie, jessie-kfreebsd
  • size: 70,324 kB
  • ctags: 39,977
  • sloc: ansic: 350,299; vhdl: 34,227; yacc: 27,122; sh: 12,416; cpp: 9,478; makefile: 7,057; lex: 3,684
file content (30 lines) | stat: -rw-r--r-- 990 bytes parent folder | download | duplicates (4)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
AC_DEFUN([ALC_CXX_PROBLEMATIC_OLD_VERSION],
[
AC_REQUIRE([AC_PROG_CXX])
AC_MSG_CHECKING(if this is a problematic old ${CXX} version)
AC_CACHE_VAL(alc_cv_cxx_problematic_version,
[
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
AC_TRY_CPP([
#ifdef __GNUC__
#if __GNUC__ < 2
#error ALC works best with GCC version 2.95.2 or higher
#endif /* __GNUC__ < 2 */
#ifdef __GNUC_MINOR__
#if __GNUC__ == 2 && __GNUC_MINOR__ < 95
#error ALC works only with GCC version 2.95.2 or higher
#endif /* __GNUC_MINOR__ < 95.2 */
#endif /* defined(__GNUC_MINOR__) */
#endif /* defined(__GNUC__) */
],
alc_cv_cxx_problematic_version=no, alc_cv_cxx_problematic_version=yes)
AC_LANG_RESTORE
])
AC_MSG_RESULT($alc_cv_cxx_problematic_version)
if test "$alc_cv_cxx_problematic_version" = yes; then
AC_MSG_ERROR(*** This package works only with ${CXX} version 2.95.2 or higher ... please install gcc 2.95.2 or higher or set the environment variable CC and CXX to the good gcc before running the configure script ***)
fi
])dnl
dnl
dnl