File: changelog

package info (click to toggle)
amide 1.0.5-13
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 6,428 kB
  • sloc: ansic: 50,849; sh: 11,297; cpp: 2,032; xml: 1,655; makefile: 645
file content (307 lines) | stat: -rw-r--r-- 9,737 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
amide (1.0.5-13) unstable; urgency=medium

  [ Steffen Moeller ]
  * d/u/metadata: yamllint
  * d/u/metadata: yamllint

  [ Gert Wollny ]
  * d/p/fix_gcc10: Fix build with gcc-10 Closes: #956997
  * Fix spelling error
  * d/rules: remove --as-needed patch
  * d/control: Fix mailinglist address

 -- Gert Wollny <gewo@debian.org>  Sun, 26 Apr 2020 10:11:32 +0200

amide (1.0.5-12) unstable; urgency=medium

  * Drop scroolkeeper from Build-Depends
    Closes: #911564
  * Standards-Version: 4.2.1

 -- Andreas Tille <tille@debian.org>  Tue, 23 Oct 2018 14:09:44 +0200

amide (1.0.5-11) unstable; urgency=medium

  * Remove Dominique Belhachemi from Uploaders
  * Build-Depends: libmdc-dev (instead of libmdc2-dev)
  * debhelper 11
  * Point Vcs fields to salsa.debian.org
  * Standards-Version: 4.1.4
  * Delete unneeded get-orig-source target

 -- Andreas Tille <tille@debian.org>  Sat, 16 Jun 2018 16:55:26 +0200

amide (1.0.5-10) unstable; urgency=medium

  * d/p/ffmpeg-35: fix compilation with ffpeg-3.5, Closes: #888342

 -- Gert Wollny <gewo@debian.org>  Sun, 28 Jan 2018 12:12:39 +0100

amide (1.0.5-9) unstable; urgency=medium

  * d/rules, d/p: Disable gconf and gnome-vfs, Closes: #868383
  * d/control: remove build dep on libgnomeui 
  * d/control: update standards to 4.1.2 (no changes)
  * d/NEWS: Add a news entry to inform about loss of old configs

 -- Gert Wollny <gewo@debian.org>  Fri, 12 Jan 2018 10:46:18 +0100

amide (1.0.5-8) unstable; urgency=medium

  [ Gert Wollny ]
  * remove autdated gnome macros and switch to yelp 
    Closes: #830051
  * remove dependencies that are default with dh 10 
  * disable GTK-DOC test since libarary documentation is not 
    build 
  * update my uploader address

  [ Andreas Tille ]
  * debhelper 10
  * Move packaging from SVN to Git

  [ Gert Wollny ]
  * 

 -- Gert Wollny <gewo@debian.org>  Sun, 24 Sep 2017 12:22:10 +0000

amide (1.0.5-7) unstable; urgency=medium

  * cme fix dpkg-control
  * Build-Depends: gnome-common
    Closes: #837817
  * hardening=+all

 -- Andreas Tille <tille@debian.org>  Thu, 15 Sep 2016 08:35:14 +0200

amide (1.0.5-6) unstable; urgency=medium

  * d/p: Add patch libc_2.23.patch Closes: #818818
  * d/control: Update standards version to 3.9.7
  * d/control: Set VCS url to https

 -- Gert Wollny <gw.fossdev@gmail.com>  Mon, 21 Mar 2016 10:21:19 +0000

amide (1.0.5-5) unstable; urgency=medium

  * d/patches/gsl_2x.patch: Fix compilation against GSL >= 2.0
    Closes: #805748
  * Update build dependency from libgsl0-dev to libgsl-dev 
    (Thanks: Bas Couwenberg)

 -- Gert Wollny <gw.fossdev@gmail.com>  Sun, 22 Nov 2015 14:31:55 +0100

amide (1.0.5-4) unstable; urgency=medium

  * Add patch to support ffmpeg-2.9, Closes: #803798
    Thanks to Andreas Cadhalpun
  * d/control: Change dependency from libdcmtk2-dev to libdcmtk-dev 
  * Remove d/amide.menu since this is now handled by the .desktop file 
    Quells lintian warning: command-in-menu-file-and-desktop-file

 -- Gert Wollny <gw.fossdev@gmail.com>  Tue, 03 Nov 2015 13:42:42 +0100

amide (1.0.5-3) unstable; urgency=medium

  * Enhanced description
    Closes: #779706

 -- Andreas Tille <tille@debian.org>  Mon, 27 Apr 2015 09:29:03 +0200

amide (1.0.5-2) unstable; urgency=medium

  * Enhanced patch allows one to build also against libav in unstable
  * New upstream version in unstable
    Closes: #703076

 -- Andreas Tille <tille@debian.org>  Wed, 26 Feb 2014 09:09:59 +0100

amide (1.0.5-1) experimental; urgency=low

  * New upstream version (adapted patches)
  * debian/upstream/metadata: Add publication data
  * debian/patches/libav10.patch: Fix compilation against libav 10
    (Thanks to Reinhard Tartler <siretart@tauware.de> for the patch)
    Closes: #739211
    The patch goes only to experimental so for the moment we also
    upload to experimental
  * cme fix dpkg-control
  * Build-Depends: libavutil-dev ( >= 6:10~alpha2-1~ )

 -- Andreas Tille <tille@debian.org>  Mon, 24 Feb 2014 15:30:19 +0100

amide (1.0.4-1) unstable; urgency=low

  * New upstream version (adapted patch)
    Closes: #653365
  * debian/gcc-4.8_format-securit.patch: Make sure package builds even
    with --format-security enabled (hardening flags)
  * debian/control:
     - cme fix dpkg-control
     - debhelper 9
     - anonscm in Vcs fields
  * Make use of dh-autoreconf
    Closes: #653366
  * debian/patches/deprecated-libav.patch: recent libavcodec removed
    some more deprecated functions (thanks for the patch to
    Andreas Moog <andreas.moog@warperbbs.de>)
    Closes: #720779
  * deactivate doc creation because it breaks the build process.  Any
    help to get this running again is appreciated (see debian/rules)
  * debian/rules: Propagate hardening options

 -- Andreas Tille <tille@debian.org>  Mon, 26 Aug 2013 14:53:06 +0200

amide (1.0.1-1) unstable; urgency=low

  * debian/README.source: removed because it is redundant
  * debian/control:
    - Fixed Vcs-Svn
    - Removed quilt from Build-Depends
  * debian/install: Make use of dh_install
  * debian/rules: 
    - Remove unknown option --enable-rpm-install from configure
      arguments
    - rewritten to make use of
       dh --with autotools_dev
  * debian/deletable.files: Removed.  There is no need to hack
    around broken upstream tarballs.  Upstream contains some *.bak
    files which are cleaned up in upstream clean target
  * debian/autogen.sh:
    Not needed when properly using autotools-dev

 -- Andreas Tille <tille@debian.org>  Mon, 09 Jan 2012 13:28:04 +0100

amide (1.0.0-1) unstable; urgency=low

  * New upstream release
  * update watch file to scan 1.x branch
  * fix vcs field

 -- Dominique Belhachemi <domibel@debian.org>  Sat, 17 Sep 2011 21:07:29 -0400

amide (0.9.3-1) unstable; urgency=low

  * New upstream version
  * Removed debian/get-orig-source which is not needed because
    uscan works perfectly and thus use uscan in debian/rules
  * debian/control:
    - Standards-Version: 3.9.1 (no changes needed)
    - Debhelper 8
    - Build-Depends: libdcmtk2-dev (instead of libdcmtk1-dev)
  * debian/source/format: 3.0 (quilt)
  * debian/rules: Deleted some useless comments
  * debian/patches/20_fix_add_needed.diff: Removed because applied
    upstream
  * debian/patches/10_all.diff: Make sure -lavcodec and -lavutil
    is propagated to the linker

 -- Andreas Tille <tille@debian.org>  Thu, 24 Mar 2011 15:02:45 +0100

amide (0.9.2-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Bug fix: "FTBFS with --no-add-needed, missing -lavutil", thanks to
    Julien Cristau (Closes: #614725).

 -- Reinhard Tartler <siretart@tauware.de>  Fri, 25 Feb 2011 15:54:15 +0100

amide (0.9.2-1) unstable; urgency=low

  * New upstream release
  * put amide under Debian Med team maintenance
  * changed patch system: using quilt instead of dpatch
  * added dependency: libavcodec-dev for fly through video generation

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Sun, 20 Dec 2009 13:38:23 -0500

amide (0.9.1-5) unstable; urgency=low

  * debian/control: removed build dependency to libglib1.2-dev
                    and libglib1.2-dev (Closes: #523561)
  * debian/control: Standards-Version: 3.8.1
  * debian/changelog: updated references to GPL-2 and LGPL-2

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Sun, 12 Apr 2009 13:01:46 -0400

amide (0.9.1-4) unstable; urgency=low

   * debian/compat: bumped up to 7
   * debian/rules: uses "dh_prep" now instead of "dh_clean -k"
   * desktop category is now: Categories=Graphics;MedicalSoftware;
   * Add var/lib/scrollkeeper to debian/dirs to so that scrollkeeper-update
     can use it when run by the build system.
   * debugging symbols disabled
   * debian/copyright: is now machine-interpretable

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Wed, 19 Feb 2009 09:21:05 -0500

amide (0.9.1-3) unstable; urgency=low

  * fixed lintian warning: doc-base-uses-applications-section
  * debian/control: Standards-Version: 3.8.0
  * debian/control: DM-Upload-Allowed: yes

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Fri, 14 Nov 2008 17:10:08 +0100

amide (0.9.1-2) unstable; urgency=low

   * debian/control: removed builddep libniftiio1-dev (Closes: #460358)
   * fixed implicit pointer conversion (Closes: #457987)

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Sun, 13 Jan 2008 10:53:11 +0200


amide (0.9.1-1) unstable; urgency=low

   * New upstream release
   * debian-policy 3.7.3 ready

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Thu, 20 Dec 2007 22:33:35 +0200


amide (0.8.22-2) unstable; urgency=low

  * debian/control: libvolpack1-dev added

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Sun, 16 Dec 2007 23:13:12 +0200


amide (0.8.22-1) unstable; urgency=low

   * New upstream release
   * make use of autoconf in debian/rules file
   * small bug-fixes
   * Back to menu-1 format
   * all changes can be found in debian/patches folder

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Sat, 23 Nov 2007 19:13:12 +0200


amide (0.8.21-4) unstable; urgency=low

  * debian/control: libniftiio1-dev dependency is updated

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Mon, 16 Sep 2007 22:10:46 +0200


amide (0.8.21-3) unstable; urgency=low

  * debian/copyright : Add documentation license (GFDL) without optional features.

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Sat, 28 Jul 2007 02:54:46 +0200


amide (0.8.21-2) unstable; urgency=low

  * Add missing libglib1.2-dev dependency.

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Wed, 18 Jul 2007 01:42:45 +0200


amide (0.8.21-1) unstable; urgency=low

  * Initial release (Closes: #409913)

 -- Dominique Belhachemi <domibel@cs.tu-berlin.de>  Sun, 15 Jul 2007 21:32:15 +0200