File: changelog

package info (click to toggle)
android-platform-tools-base 2.2.2-3
  • links: PTS, VCS
  • area: main
  • in suites: sid
  • size: 124,104 kB
  • sloc: java: 826,530; xml: 45,920; cpp: 2,526; ansic: 1,432; sh: 508; lisp: 110; makefile: 21
file content (150 lines) | stat: -rw-r--r-- 5,687 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
android-platform-tools-base (2.2.2-3) unstable; urgency=medium

  * use minimal proguard packages to avoid pulling in GUI
  * point Vcs tags to salsa.debian.org
  * Standards-Version: 4.1.3 no changes
  * make license check a warning instead of an error (Closes: #883074)
  * fix launcher shell script for screenshot2 command
  * fix missing-notice-file-for-apache-license

 -- Hans-Christoph Steiner <hans@eds.org>  Wed, 28 Feb 2018 16:40:52 +0100

android-platform-tools-base (2.2.2-2) unstable; urgency=medium

  * New using_Debian_Android_SDK.patch: When using Debian's Android SDK, the
    plugin will select the best `android.jar` and Build-Tools available.
  * d/control:
    * Suggests android-debian-helper that helps using the Gradle plugin provided
      by this package.
    * Depends on JDK8 since the code uses Java 8 Streams and lambda.

 -- Kai-Chung Yan <seamlikok@gmail.com>  Tue, 28 Feb 2017 19:37:48 +0800

android-platform-tools-base (2.2.2-1) unstable; urgency=medium

  [ Hans-Christoph Steiner ]
  * New upstream release (Closes: #850997)
  * Team upload

  [ Kai-Chung Yan ]
  * New BDs:
    * libbatik-java
    * libautomaton-java
    * libcglib-java
    * libjdom1-java
    * libjna-java
    * libjna-platform-java
    * libjoptsimple-java
    * liboro-java
  * Remove BD: libtrove3-java but use its fork from intellij-community
  * No longer build testutils
  * New patch disable_lint-cli_psi.patch

 -- Kai-Chung Yan <seamlikok@gmail.com>  Wed, 25 Jan 2017 22:11:21 +0800

android-platform-tools-base (2.0.0-2) unstable; urgency=medium

  * Switch to libasm-java instead of libasm4-java (Closes: #839745)
  * build.gradle.patch:
    * Set compiler encoding to UTF-8 otherwise encoding errors
    * Remove non-existing gradle properties
    * Bring compatibility with Gradle 3.x (Closes: #844959)
  * d/control:
    * Let libandroid-ddms-java depends on adb
    * Build-Depends on default-jdk-headless | default-jdk (>= 1:1.6)
  * d/android-platform-tools-base.links: No longer provide symlinks to JARs in
    ANDROID_HOME. This is unnecessary.
  * Bring back profile.jar
  * Update to debhelper 10
  * Let gradle-debian-helper generate Maven POMs
    * Build-Depends on gradke-debian-helper (>= 1.4~)
  * d/libgradle-android-plugin-java-doc.lintian-overrides: Ignore
    duplicate-files as they are example files not mistakes
  * d/maven.rules: Use version "debian" of bouncycastle
  * New Gradle_3.patch: Bring compatibility with Gradle 3.x

 -- Kai-Chung Yan <seamlikok@gmail.com>  Thu, 01 Dec 2016 17:41:01 +0800

android-platform-tools-base (2.0.0-1) unstable; urgency=medium

  [ Markus Koschany ]
  * Remove myself from Uploaders.

  [ Chirayu Desai ]
  * Add maxParallelForksSingleCPU.patch.
    Upstream uncondtionally set maxParallelForks to available processors
    which would equal 0.5 if there was only a single processor. Make it
    conditional so that the default value of 1 is used in cases where available
    processors are < 2. (Closes: #834753)

  [ Kai-Chung Yan ]
  * New upstream release
  * Use get-orig-source to generate upstream tarball
    - Refactor the upstream file structure based on that
  * New Build-Depends:
    - libandroid-databinding-java
    - antlr3
  * d/copyright: Exclude more binary files and non-free files
  * d/control:
    - Unify Maintainer to "Android Tools Maintainers"
    - Add myself to Uploaders
    - Move Vcs repo to android-tools
  * New Inception-Date.patch: Manually set Inception-Date in some JARs' manifest
    for reproducibility
  * New packages:
    * libgradle-android-plugin-java(-doc)
    * libandroid-ddms-java
    * libandroid-layoutlib-api-java
    * libandroid-tools-dvlib-java
    * libandroid-tools-repository-java
  * No longer build the folowwing as they are unused:
      * chartlib.jar
      * generate-local-data.jar
      * lint-tests.jar
      * nin9patch.jar
      * perflib.jar
      * profile.jar
      * rule-api.jar
  * No longer build against libandroid-tools-common-java or
    libandroid-tools-annotations-java which introduces self-dependencies
  * Install JARs into maven-repo
  * Generate Class-Paths for the Java programs and store them in
    /usr/share/android-platform-tools-base

 -- Kai-Chung Yan <seamlikok@gmail.com>  Fri, 26 Aug 2016 22:19:07 +0200

android-platform-tools-base (1.5.0-4) unstable; urgency=medium

  * No-change rebuild because of bug #805228.

 -- Markus Koschany <apo@debian.org>  Thu, 14 Jul 2016 23:28:15 +0200

android-platform-tools-base (1.5.0-3) unstable; urgency=medium

  * Declare compliance with Debian Policy 3.9.8.
  * Build-Depend on libhttpcore-java.
  * Add libhttpcore-java-ThreadSafe.patch.
    Replace removed ThreadSafe annotation class with custom built annotations.
    Thanks to Chris Lamb for the report. (Closes: #828813)
  * Remove jlibs files and javahelper build-dependency. Make use of
    maven_repo_helper's --java-lib option instead.
  * Build-Depend on Groovy and update build.gradle.patch to fix build failure
    Cannot infer Groovy class path because no Groovy Jar was found on class
    path.

 -- Markus Koschany <apo@debian.org>  Wed, 13 Jul 2016 21:34:58 +0200

android-platform-tools-base (1.5.0-2) unstable; urgency=medium

  * Drop disable-lint.patch and build Lint because the new build-dependency
    liblombok-ast-java is available now.
  * Add liblombok-ast-java to Build-Depends.
  * Update package description and mention Android's Lint tool.

 -- Markus Koschany <apo@debian.org>  Wed, 23 Mar 2016 14:08:28 +0100

android-platform-tools-base (1.5.0-1) unstable; urgency=medium

  * Initial release. (Closes: #814797)

 -- Markus Koschany <apo@debian.org>  Thu, 18 Feb 2016 00:47:02 +0100