File: changelog

package info (click to toggle)
android-sdk-meta 28.0.2%2B3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 160 kB
  • sloc: xml: 172; makefile: 31; sh: 10
file content (225 lines) | stat: -rw-r--r-- 7,796 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
android-sdk-meta (28.0.2+3) unstable; urgency=medium

  * Team upload.

  [ Thorsten Glaser ]
  * Mark arch:all packages as Multi-Arch: foreign (Closes: #980644)

  [ Hans-Christoph Steiner ]
  * update version numbers in package.xml files

 -- Hans-Christoph Steiner <hans@eds.org>  Fri, 22 Jan 2021 10:23:31 +0100

android-sdk-meta (28.0.2+2) unstable; urgency=medium

  * Team upload.
  * rework udev rules autopkgtest to use auto-arch detection

 -- Hans-Christoph Steiner <hans@eds.org>  Mon, 18 Jan 2021 11:37:14 +0100

android-sdk-meta (28.0.2+1) unstable; urgency=medium

  * Team Upload

  [ Debian Janitor ]
  * Use correct machine-readable copyright file URI.
  * Bump debhelper from old 10 to 12.
  * Set debhelper-compat version in Build-Depends.
  * Update standards version to 4.4.1, no changes needed.
  * Update standards version to 4.5.0, no changes needed.

  [ Hans-Christoph Steiner ]
  * support all valid package revisions in the meta package versions
  * create source.properties in proper Java Properties format
  * include new udev rules from upstream source
  * add autopkgtest for current Google-recommended install method

  [ Samyak Jain ]
  * Adds Huawei P10 Lite to udev rules (Closes: #941260)
  * Rules-Requires-Root: no

 -- Samyak Jain <samyak.jn11@gmail.com>  Fri, 05 Jun 2020 10:28:12 +0530

android-sdk-meta (25.0.0+12) unstable; urgency=medium

  * no need for JDK in Depends:, apksigner and dalvik-exchange
    already have it
  * Revert "remove broken screenshot2 symlink (Closes: #924175)
  * fix regex for adding Debian version to binary packages
    (Closes: #935938)

 -- Hans-Christoph Steiner <hans@eds.org>  Thu, 29 Aug 2019 23:22:43 +0200

android-sdk-meta (25.0.0+11) unstable; urgency=medium

  [ Jeff Muizelaar ]
  * Add some more Amazon devices

  [ Hans-Christoph Steiner ]
  * fix DEB_REVISION parsing to work with more than one digit
  * remove broken screenshot2 symlink (Closes: #924175)
  * Suggests: proguard-gui for symlinks (Closes: #923935)
  * document udev rule for providing device access to the console user
  * update udev rules to latest upstream version (Closes: #931215)
  * sync new devices in 51-android.rules from upstream
  * Standards-Version 4.3.0 no changes
  * sync whitespace in 51-android.rules with upstream
  * sync comments in 51-android.rules with upstream
  * sync manufacturer order in 51-android.rules from upstream

 -- Hans-Christoph Steiner <hans@eds.org>  Thu, 27 Jun 2019 22:16:12 +0200

android-sdk-meta (25.0.0+10) unstable; urgency=medium

  * drop packages with impossible arches from meta Depends

 -- Hans-Christoph Steiner <hans@eds.org>  Thu, 07 Mar 2019 10:35:06 +0000

android-sdk-meta (25.0.0+9) unstable; urgency=medium

  [ Jeremy Bicha ]
  * android-sdk-platform-tools: Don't require adb or fastboot on mips*

  [ 殷啟聰 | Kai-Chung Yan ]
  * Update versions of SDK components to match upstream

  [ Hans-Christoph Steiner ]
  * fix missing idProduct values in udev rules
  * add autopkgtest for udev rules
  * add autopkgtest for `apt-get install android-tools-adb`
  * add debian/.gitlab-ci.yml to run tests on GitLab CI
  * update alternative Depends: for current Java versions (Closes: #922555)
  * purge dependencies not in buster

 -- Hans-Christoph Steiner <hans@eds.org>  Wed, 06 Mar 2019 23:06:35 +0000

android-sdk-meta (25.0.0+8) unstable; urgency=medium

  * include /usr/bin/screenshot2 as symlink
  * also support Oracle JDK, do not require only OpenJDK
  * add alternate vendor ID for Fairphone 2

 -- Hans-Christoph Steiner <hans@eds.org>  Wed, 21 Mar 2018 09:47:16 +0100

android-sdk-meta (25.0.0+7) unstable; urgency=medium

  * tighten up udev rules

 -- Hans-Christoph Steiner <hans@eds.org>  Thu, 01 Mar 2018 12:23:06 +0100

android-sdk-meta (25.0.0+6) unstable; urgency=medium

  * use HTTPS URL for debian/copyright
  * point Vcs tags to salsa.debian.org
  * Standards-Version: 4.1.3 no changes
  * add new vendors to udev rules (Closes: #877704)
  * switch from plugdev to uaccess (Closes: #882688)

 -- Hans-Christoph Steiner <hans@eds.org>  Thu, 01 Mar 2018 01:01:47 +0100

android-sdk-meta (25.0.0+5) unstable; urgency=medium

  * correct my git mistake, this has all of +3 and +4

 -- Hans-Christoph Steiner <hans@eds.org>  Mon, 13 Mar 2017 11:43:41 +0100

android-sdk-meta (25.0.0+4) unstable; urgency=medium

  * d/rules: Automate the Debian revision in the versions of binary packages

 -- Kai-Chung Yan <seamlikok@gmail.com>  Mon, 13 Mar 2017 18:07:22 +0800

android-sdk-meta (25.0.0+3) unstable; urgency=medium

  * udev rules for Intel tablets (Closes: #814056)
  * update debian/changelog for upload
  * add myself to Uploaders
  * fix grammar mistake in description (Closes: #855542)
  * only Depend on proguard-cli (Closes: #856410)

 -- Hans-Christoph Steiner <hans@eds.org>  Fri, 10 Mar 2017 22:23:19 +0100

android-sdk-meta (25.0.0+2) unstable; urgency=medium

  * Install licenses directory in android-sdk-common

 -- Kai-Chung Yan <seamlikok@gmail.com>  Tue, 07 Feb 2017 22:38:05 +0800

android-sdk-meta (25.0.0+1) unstable; urgency=medium

  * Add package.xml for Build-tools and Platform-tools
  * Add licenses/ directory. See README.source for explanation.

 -- Kai-Chung Yan <seamlikok@gmail.com>  Tue, 13 Dec 2016 00:50:13 +0800

android-sdk-meta (25.0.0) unstable; urgency=medium

  * Tracking new upstream versions:
    * SDK => 25.0.0
    * Build-tools => 24.0.0
    * Platform-tools => 24.0.0
    * AOSP tags:
      * gradle_${latest} => gradle_2.0.0
      * android-${latest} => android-7.0.0_r1
  * Put default-jdk-headless to Recommends: JDK isn't necessary for running the
    SDK.
  * Add a "runtime.properties" file to build-tools
  * Add a "package.xml" to tools
  * Enable builds for ARM & MIPS
  * Install Build-tools of version "debian" and create a symlink of the real
    version to it.
  * Add d/README.* to explain the origins of some files

 -- Kai-Chung Yan <seamlikok@gmail.com>  Sun, 11 Dec 2016 20:44:23 +0800

android-sdk-meta (24.3.3+4) unstable; urgency=medium

  * Update to debhelper 10
  * No longer install symlinks to shared libraries or SWT (Closes: #840044)
  * d/control:
    * Unify the Maintainer name to "Android Tools Maintainers"
    * Recommends libgradle-android-plugin-java
    * Suggests android-sdk-platform-23
    * Depends on android-platform-tools-base

 -- Kai-Chung Yan <seamlikok@gmail.com>  Wed, 30 Nov 2016 18:17:13 +0800

android-sdk-meta (24.3.3+3) unstable; urgency=medium

  [ Chirayu Desai ]
  * d/control: android-sdk depends on default-jdk (Closes: #826761)

  [ Mouaad Aallam ]
  * d/control: android-sdk recommends gradle (Closes: #826870)
               android-sdk suggests maven
  * Add llvm-rs-cc stub. (Temporarily, for #827215)

  [ Markus Koschany ]
  * Declare compliance with Debian Policy 3.9.8.
  * d/control: android-sdk depends on default-jdk | java8-runtime.

 -- Chirayu Desai <chirayudesai1@gmail.com>  Sat, 20 Aug 2016 12:35:40 +0530

android-sdk-meta (24.3.3+2) unstable; urgency=medium

  * d/control: android-sdk-platform-tools depends
    android-sdk-platform-tools-common(>= 23), android-sdk-build-tools depends
    android-sdk-build-tools-common(>= 23.0.2)

 -- Kai-Chung Yan <seamlikok@gmail.com>  Sun, 28 Feb 2016 16:33:45 +0800

android-sdk-meta (24.3.3+1) unstable; urgency=medium

  * d/android-sdk.links: Set mode executable (for dh-exec) (Closes: #815340)
  * d/control:
    - Architectures of all common packages set to "all"
    - android-sdk-platform-tools depends on android-sdk-platform-tools-common
      (Closes: #815332)

 -- Kai-Chung Yan <seamlikok@gmail.com>  Sun, 21 Feb 2016 15:02:26 +0800

android-sdk-meta (24.3.3) unstable; urgency=low

  * Initial release

 -- Kai-Chung Yan <seamlikok@gmail.com>  Wed, 17 Feb 2016 16:13:22 +0800