1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56
|
Author: Gert Wollny <gw.fossdev@gmail.com
Last-Update: Wed, 08 Jan 2014 11:55:33 +0100
Description: Correct ordering of template declarations to honor new scope rules
diff -ur -x Makefile.in anfo-0.98/src/stream.h anfo-0.98.debian/src/stream.h
@@ -141,6 +141,9 @@
output::Hit* mutable_hit_to( output::Result* ) ;
output::Hit* mutable_hit_to( output::Result*, const string& ) ;
+inline output::Hit::Operation cigar_op( uint32_t c ) { return (output::Hit::Operation)(c & 0xf) ; }
+inline uint32_t cigar_len( uint32_t c ) { return c >> 4 ; }
+
//! \brief computes (trimmed) query length from CIGAR line
template< typename C > unsigned len_from_bin_cigar( const C& cig )
{
@@ -166,8 +169,6 @@
return l ;
}
-inline output::Hit::Operation cigar_op( uint32_t c ) { return (output::Hit::Operation)(c & 0xf) ; }
-inline uint32_t cigar_len( uint32_t c ) { return c >> 4 ; }
inline uint32_t mk_cigar( output::Hit::Operation op, uint32_t len ) { return len << 4 | op ; }
inline void push_op( std::vector<unsigned>& s, unsigned m, output::Hit::Operation op )
diff -ur -x Makefile.in anfo-0.98/src/util.h anfo-0.98.debian/src/util.h
@@ -44,6 +44,13 @@
}
template< typename T >
+T throw_errno_if_eq( T x, T y, const char* a, const char* b = 0 )
+{
+ if( x == y ) throw_errno( a, b ) ;
+ return x ;
+}
+
+template< typename T >
T throw_errno_if_minus1( T x, const char* a, const char* b = 0 )
{ return throw_errno_if_eq( x, (T)(-1), a, b ) ; }
@@ -51,12 +58,6 @@
T throw_errno_if_null( T x, const char* a, const char* b = 0 )
{ return throw_errno_if_eq( x, (T)0, a, b ) ; }
-template< typename T >
-T throw_errno_if_eq( T x, T y, const char* a, const char* b = 0 )
-{
- if( x == y ) throw_errno( a, b ) ;
- return x ;
-}
template< typename T >
T throw_if_negative( T x, const char* a, const char* b = 0 )
|