File: changelog

package info (click to toggle)
antlr3 3.5.2-9
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 7,548 kB
  • sloc: java: 92,547; xml: 851; makefile: 49; sh: 19
file content (290 lines) | stat: -rw-r--r-- 10,068 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
antlr3 (3.5.2-9) unstable; urgency=medium

  * Team upload.
  * Declare compliance with Debian Policy 4.1.3.
  * antlr3: Only depend on default-jre-headless | java7-runtime-headless.
  * Use https for Format field.
  * Fix FTBFS with Java 9.
    Thanks to Tiago Stürmer Daitx for the patch. (Closes: #892760)

 -- Markus Koschany <apo@debian.org>  Tue, 20 Mar 2018 21:34:54 +0100

antlr3 (3.5.2-8) unstable; urgency=medium

  * Team upload.
  * Depend on libmaven3-core-java instead of libmaven2-core-java

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 02 Aug 2017 11:53:56 +0200

antlr3 (3.5.2-7) unstable; urgency=medium

  * Team upload.
  * Added the missing build dependency on junit4 (Closes: #866549)
  * Standards-Version updated to 4.0.0

 -- Emmanuel Bourg <ebourg@apache.org>  Fri, 30 Jun 2017 11:15:48 +0200

antlr3 (3.5.2-6) unstable; urgency=medium

  * Team upload.
  * Restored the Export-Package field in the OSGi metadata
  * Switch to debhelper level 10

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 07 Nov 2016 13:54:43 +0100

antlr3 (3.5.2-5) unstable; urgency=medium

  * Team upload.
  * Added the missing build dependency on ant (Closes: #814723)
  * Standards-Version updated to 3.9.8
  * Use a secure Vcs-Git URL

 -- Emmanuel Bourg <ebourg@apache.org>  Sun, 26 Jun 2016 18:49:21 +0200

antlr3 (3.5.2-4) unstable; urgency=medium

  * Fixed the build failure with Maven 3 (Closes: #807733)

 -- Emmanuel Bourg <ebourg@apache.org>  Sat, 12 Dec 2015 22:14:20 +0100

antlr3 (3.5.2-3) unstable; urgency=medium

  * Team upload.

  [ Emmanuel Bourg ]
  * Declare that ANTLR 3.5 breaks jython (<< 2.5.3-7~)
  * Replaced the HashSets with LinkedHashSets in DefineGrammarItemsWalker
    to make the generated parsers reproducible
  * d/README.source: Updated the instructions to build the generated sources
  * Removed the unused dependency on libantlr-maven-plugin-java
  * Require Java 5 or higher
  * Fixed the library package suggested by antlr3-doc
  * Changed the section of the manpage (3 -> 1)

  [ Markus Koschany ]
  * Vcs-Browser: Use https.
  * Transition to bnd 2.1.0.
  * Add a new maven rule for antlr2, otherwise the build FTBFS.
  * Fix Lintian warning spelling-error-in-description.

 -- Markus Koschany <apo@debian.org>  Thu, 19 Nov 2015 19:06:16 +0100

antlr3 (3.5.2-2) unstable; urgency=medium

  * Team upload.
  * Moved the runtime into a separate libantlr3-runtime-java package
    to avoid a dependency cycle with libstringtemplate4-java (Closes: #793715)

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 29 Jul 2015 19:54:55 +0200

antlr3 (3.5.2-1) unstable; urgency=medium

  * New upstream release (Closes: #635268)
    - Removed java{7,8}-compat.patch (fixed upstream)
    - Ignore the new modules: antlr-complete, antlr3-maven-archetype
    - Added a dependency on libstringtemplate4-java
    - Refreshed debian/generated-sources
    - Updated the man page
    - Backported two fixes for the C template
    - Patched the org.antlr.runtime.Token class to preserve the EOF_TOKEN field
  * debian/rules:
    - Changed the bnd command to work with any upstream version
    - Remove the antlr3 artifacts from debian/maven-repo before invoking Maven
      (Closes: #706172)
    - Improved the clean target
  * Build and install the Ant task (Closes: #590699)
  * Increased the default conversion timeout to 30 seconds (Closes: #779973)
  * debian/watch: Watch the release tags on Github
  * debian/orig-tar.sh:
    - Use XZ compression for the upstream tarball
    - Remove the zipped examples in the antlr-ant directory

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 22 Jul 2015 18:52:02 +0200

antlr3 (3.2-11) unstable; urgency=medium

  * Team upload.
  * Replace dependency on dummy package libplexus-compiler-api-java
    with libplexus-compiler-java (Closes: #791487)
  * Moved the package to Git
  * Bump Standards-Version to 3.9.6 (no changes).

 -- tony mancill <tmancill@debian.org>  Sat, 11 Jul 2015 10:58:15 -0700

antlr3 (3.2-10) unstable; urgency=medium

  * Fixed a NullPointerException in CompositeGrammar.getIndirectDelegates()
    with Java 8
  * Standards-Version updated to 3.9.5 (no changes)
  * Switch to debhelper level 9

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 07 Apr 2014 14:22:17 +0200

antlr3 (3.2-9) unstable; urgency=low

  * Team upload.

  [ Jakub Adam ]
  * Add OSGi metadata to antlr3.jar and antlr3-runtime.jar.
  * Add Jakub Adam to Uploaders.

  [ tony mancill ]
  * Clean up lintian warning about BSD license in debian/copyright.

 -- tony mancill <tmancill@debian.org>  Sun, 29 Sep 2013 09:38:53 -0700

antlr3 (3.2-8) unstable; urgency=low

  * Updated Standards-Version to 3.9.4 (no changes)
  * Updated the watch file
  * Converted debian/copyright to the DEP5 format
  * Added a clean target to debian/rules to allow rebuilds
  * Use canonical URLs for the Vcs-* fields
  * Fixed syntax issues in the manpages

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 03 Jul 2013 13:27:44 +0200

antlr3 (3.2-7) unstable; urgency=low

  * Team upload.

  [ tony mancill ]
  * Remove Michal Koch from Uploaders. (Closes: #653985)

  [ James Page ]
  * Fix FTBFS with openjdk-7:
    - d/patches/java7-compat.patch: Target 1.5 instead of jsr14 which is
      not supported by Java 7.

 -- James Page <james.page@ubuntu.com>  Sat, 23 Jun 2012 13:14:52 +0200

antlr3 (3.2-6) unstable; urgency=low

  * Team upload.
  * Add missing Build-Depends: libmaven-plugin-tools-java. (Closes: #643493)
  * Do no longer build antlr3-gcj.

 -- Torsten Werner <twerner@debian.org>  Tue, 27 Sep 2011 22:49:38 +0200

antlr3 (3.2-5) unstable; urgency=low

  * Team upload.
  * d/rules: Set DEB_MAVEN_BUILD_TARGET := package install
    so that JAR will be installed in temporary maven repository.
    This should please javadoc:jar plugin. (Closes: #606294)
    (ie. it won't try to download antlr-gunit module from network).
  * d/control: Build-Depends on libmaven-install-plugin-java to get
    "install" lifecycle working.

 -- Damien Raude-Morvan <drazzib@debian.org>  Sat, 08 Jan 2011 01:55:34 +0100

antlr3 (3.2-4) unstable; urgency=low

  [ Ludovic Claude ]
  * Rebuild with a newer version of maven-debian-helper (Closes: #587499)
  * maven.rules: transform antlr 3 versions to '3.x' instead of 'debian'
  * Split packaging of gUnit jar into new libantlr3-gunit-java package
    and gUnit Maven plugin into new antlr3-gunit-maven-plugin package,
    split Maven plugin for Antlr into new antlr3-maven-plugin package
    (Closes: #588005)
  * Update dependencies of antlr3, remove the dependencies coming from
    those 3 new packages.

  [ Niels Thykier ]
  * Fixed a typo in the control so antlr3 now properly suggests
    antlr3-gcj.
  * Reduced the alternative JREs to headless versions.
  * Bumped Standards-Versions to 3.9.0 - no changes required.
  * Replaced B-D on default-jdk-builddep with gcj-native-helper
    and default-jdk.

 -- Ludovic Claude <ludovic.claude@laposte.net>  Wed, 21 Jul 2010 23:22:09 +0200

antlr3 (3.2-3) unstable; urgency=low

  * Clean up build dependencies. (Closes: #587401)

 -- Torsten Werner <twerner@debian.org>  Mon, 28 Jun 2010 20:49:51 +0200

antlr3 (3.2-2) unstable; urgency=low

  [ Ludovic Claude ]
  * New upstream (Closes: #579504)
  * debian/watch fixes in previous version (Closes: #570684)
  * Add missing antlr3-runtime.jar library to antlr3 wrapper script
    (Closes #587212)
  * Also don't export the CLASSPATH variable, there's no need to affect
    the whole environement when launching this program
  * Add man page for antlr3 script

  [ Torsten Werner ]
  * Call dh_nativejava to fill the antlr3-gcj package again. (Closes: #587306)
  * Reformat a changelog entry for the last version.

 -- Torsten Werner <twerner@debian.org>  Sun, 27 Jun 2010 21:01:36 +0200

antlr3 (3.2-1) unstable; urgency=low

  [ Ludovic Claude ]
  * Upstream build now uses Maven
  * debian/control:
      - Updated Standards-Version to 3.8.4.
      - Build-Depends-Indep: add dependencies for Maven build:
        libantlr-maven-plugin-java, maven-debian-helper,
        libmaven-site-plugin-java, libstringtemplate-java,
        libmaven-javadoc-plugin-java
      - Build-Depends-Indep: add dependencies to build the Javadoc:
        default-jdk-doc, libmaven-javadoc-plugin-java
      - antlr3 Depends: remove java1-runtime, add java5-runtime
      - downgrade antlr3-gcj from Recommands: to Suggests:
      - create an antlr3-doc package that contains the documentation
      [TODO] create an antlr3-gunit package and modify maven-debian-helper to
      deploy the gunit jars to this package
  * debian/rules: remove include simple-patchsys.mk, replaced by
    source format 3.0 (quilt)
  * Add orig-tar to clean up upstream sources
  * Switch to source format 3.0 (quilt)

  [ Michael Koch ]
  * New upstream version (Closes: #511470).
  * debian/watch: Fixed by using site-local absolution download link.
  * debian/control: Updated Standards-Version to 3.8.3.
  * debian/control: Added Homepage field.

  [ Torsten Werner ]
  * Remove Build-Depends: quilt.

 -- Torsten Werner <twerner@debian.org>  Tue, 22 Jun 2010 14:53:06 +0200

antlr3 (3.0.1+dfsg-4) unstable; urgency=low

  * Fix build failure for binary-arch only builds. Closes: #502660.
  * Compile java files with -source 1.4.

 -- Matthias Klose <doko@debian.org>  Thu, 23 Oct 2008 01:32:35 +0200

antlr3 (3.0.1+dfsg-3) unstable; urgency=low

  * antlr3: Depend on default-jre-headless.
  * Build an antlr3-gcj package.

 -- Matthias Klose <doko@debian.org>  Mon, 29 Sep 2008 23:18:19 +0200

antlr3 (3.0.1+dfsg-2) unstable; urgency=low

  * Add depends on libstringtemplate-java. Closes: #474719
  * Add wrapper script for antlr. Closes: #474721

 -- Michael Koch <konqueror@gmx.de>  Tue, 08 Apr 2008 20:35:27 +0200

antlr3 (3.0.1+dfsg-1) unstable; urgency=low

  * Repackaged orig tarball.

 -- Michael Koch <konqueror@gmx.de>  Mon, 31 Mar 2008 23:50:00 +0200

antlr3 (3.0.1-1) unstable; urgency=low

  * Initial version. Closes: #439725

 -- Michael Koch <konqueror@gmx.de>  Sun, 02 Mar 2008 01:40:30 +0100