1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
export VERBOSE=1
%:
dh $@ --with autoreconf
override_dh_auto_configure:
DH_COMPAT=10 dh_auto_configure -- \
--with-libwrap \
--enable-cgi \
--enable-modbus-usb \
--enable-usb \
--enable-net \
--enable-snmp \
--enable-test \
--sysconfdir=/etc/apcupsd \
--with-cgi-bin=\$${prefix}/lib/cgi-bin/apcupsd \
--with-pid-dir=/var/run \
--with-log-dir=/var/log \
--with-lock-dir=/var/lock \
--with-pwrfail-dir=/etc/apcupsd \
--disable-install-distdir \
--with-nis-port=3551 \
--with-nisip=127.0.0.1 \
--with-upstype=usb \
--with-upscable=usb \
SHUTDOWN=/sbin/shutdown
override_dh_auto_build:
dh_auto_build
make -C doc/manual manual.pdf
override_dh_installinit:
dh_installinit --no-restart-on-upgrade --init-script=apcupsd
override_dh_installchangelogs:
dh_installchangelogs ChangeLog
override_dh_compress:
dh_compress -Xusr/share/doc/apcupsd/doc
override_dh_fixperms-arch:
dh_fixperms
chmod 0755 debian/apcupsd/etc/apcupsd/killpower
chmod 0755 debian/apcupsd/etc/apcupsd/ups-monitor
chmod 0755 debian/apcupsd/lib/apcupsd/prestart
chmod 0755 debian/apcupsd/lib/systemd/system-shutdown/apcupsd_shutdown
|