1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55
|
PACKAGE=apel
ELDIR=$(CURDIR)/debian/$(PACKAGE)/usr/share/emacs/site-lisp/$(PACKAGE)
build-indep: build-indep-stamp
build-indep-stamp:
dh_testdir
touch $@
build-arch:
build: build-indep build-arch
clean:
dh_testdir
dh_testroot
rm -f *build*-stamp
dh_clean
install: build-indep
dh_testdir
dh_testroot
dh_prep
dh_installdirs
cp Makefile EMU-* APEL-* *.el $(ELDIR)/
for f in env.el timezone.el time-stamp.el; do \
if [ -f $(ELDIR)/$$f ]; then rm -f $(ELDIR)/$$f; fi; \
done
binary-indep: install
dh_testdir
dh_testroot
dh_installemacsen --priority=20
dh_installdocs
dh_installchangelogs ChangeLog
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary-arch:
binary: binary-indep binary-arch
.PHONY: build-indep build-arch build clean binary-indep binary-arch binary
|