1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
|
Description: upstream -- enhancement -- test_updating
Render Apop_stopif message emitted by eg/test_updating.c more precise.
Origin: debian
Forwarded: https://github.com/b-k/apophenia/pull/28
Author:
Jerome Benoit <calculus@rezozer.net>
Last-Update: 2015-12-02
@@ -4,7 +4,7 @@
void distances(gsl_vector *v1, gsl_vector *v2, double tol){
double error = apop_vector_distance(v1, v2, .metric='m');
double updated_size = apop_vector_sum(v1);
- Apop_stopif(error/updated_size > tol, exit(1), 0, "The error is %g, which is too big.", error/updated_size);
+ Apop_stopif(error/updated_size > tol, exit(1), 0, "The error is %g, which is too big (> %g).", error/updated_size, tol);
}
int main(){
|