File: changelog

package info (click to toggle)
async-http-client 2.11.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 3,464 kB
  • sloc: java: 32,331; xml: 923; python: 30; sh: 7; makefile: 2
file content (89 lines) | stat: -rw-r--r-- 3,093 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
async-http-client (2.11.0-1) unstable; urgency=medium

  * Team upload.
  * Update to upstream v2.11.0
  * Use debhelper-compat.
    - Update to compat level 12.
  * Update Standards-Version to 4.5.0
  * Add Rules-Requires-Root: no.
  * Use secure copyright format uri.

 -- Sudip Mukherjee <sudipm.mukherjee@gmail.com>  Tue, 14 Apr 2020 23:21:02 +0100

async-http-client (2.6.0-1) unstable; urgency=medium

  * New upstream release
    - Removed the patches (fixed upstream)
    - Build the new modules
    - Ignore the new test dependencies
    - Ignore the maven-scm extensions
    - No longer depend on libcommons-httpclient-java
    - No longer build depend on the Maven shade plugin
    - New dependency on libactivation-java, libreactive-streams-java,
      and libnetty-reactive-streams-java
    - Depend on libnetty-java instead of libnetty-3.9-java (Closes: #905859)
  * Set the source file encoding to UTF-8
  * Suggest the optional dependencies instead of recommending them
  * Removed the -doc package
  * Standards-Version updated to 4.2.1
  * Switch to debhelper level 11
  * Use salsa.debian.org Vcs-* URLs
  * Removed Damien Raude-Morvan from the uploaders
  * Removed the debian/orig-tar.sh script

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 27 Nov 2018 09:03:22 +0100

async-http-client (1.6.5-5) unstable; urgency=medium

  * Team upload.
  * Added the missing build dependency on libcommons-httpclient-java
  * Build with the DH sequencer instead of CDBS
  * Removed the unused build dependency on libanimal-sniffer-java
  * Removed the build dependency on maven-enforcer-plugin
  * Standards-Version updated to 4.1.1
  * Switch to debhelper level 10
  * Use secure Vcs-* URLs

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 20 Nov 2017 16:24:23 +0100

async-http-client (1.6.5-4) unstable; urgency=medium

  * Team upload.
  * Depend on libnetty-3.9-java instead of libnetty-java

 -- Emmanuel Bourg <ebourg@apache.org>  Tue, 28 Jul 2015 16:18:50 +0200

async-http-client (1.6.5-3) unstable; urgency=medium

  * Team upload.

  [ Emmanuel Bourg ]
  * Fixed CVE-2013-7397: SSL/TLS certificate verification is disabled
    under certain conditions (Closes: #773364)
  * Fixed a compilation error with Java 8 (Closes: #773372)
  * debian/control:
    - Standards-Version updated to 3.9.6 (no changes)
    - Removed the unnecessary build dependency on libclirr-maven-plugin-java
    - Use canonical URLs for the Vcs-* fields
  * debian/rules: Improved the clean target

  [ Tony Mancill ]
  * Update debian/watch

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 17 Dec 2014 19:14:38 +0100

async-http-client (1.6.5-2) unstable; urgency=medium

  * Team upload.
  * Update Homepage URL (Closes: #738786)
  * Bump Standards-Version to 3.9.5.
  * Update DEP5 URL in debian/copyright; address lintian warning.
  * Bump DH dependency to 9.

 -- tony mancill <tmancill@debian.org>  Wed, 12 Feb 2014 22:21:31 -0800

async-http-client (1.6.5-1) unstable; urgency=low

  * Initial release (Closes: #624538).

 -- Damien Raude-Morvan <drazzib@debian.org>  Sat, 03 Dec 2011 02:12:33 +0100