File: meson.build

package info (click to toggle)
at-spi2-atk 2.30.0-5
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 1,348 kB
  • sloc: ansic: 16,061; xml: 188; makefile: 15
file content (64 lines) | stat: -rw-r--r-- 2,095 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
project('at-spi2-atk', 'c',
        version: '2.29.1',
        license: 'LGPLv2.1+',
        default_options: [
          'buildtype=debugoptimized',
          'warning_level=1',
          'c_std=c99',
        ],
        meson_version : '>= 0.40.1')

atk_bridge_soversion = 0
atk_bridge_libversion = '0.0.0'

cc = meson.get_compiler('c')
host_system = host_machine.system()

# XXX: for strcasecmp(); should use g_ascii_strcasecmp()
add_project_arguments([ '-D_DEFAULT_SOURCE', ], language: 'c')

# We are using deprecated API; don't warn if we're building stable
# releases, to avoid making the build logs less readable. We keep
# the warnings during development cycles, to remind us we should
# port away from deprecated API
if meson.project_version().split('.').get(1).to_int().is_even()
  add_project_arguments([ '-DATK_DISABLE_DEPRECATION_WARNINGS' ], language: 'c')
endif

# XXX: Unused
at_spi_conf = configuration_data()
at_spi_conf.set('GETTEXT_PACKAGE', meson.project_name())
configure_file(output: 'config.h',
               configuration: at_spi_conf)

root_inc = include_directories('.')

# Dependencies
libdbus_req_version = '>= 1.5'
glib_req_version = '>= 2.32.0'
gobject_req_version = '>= 2.0.0'
gmodule_req_version = '>= 2.0.0'
atk_req_version = '>= 2.29.2'
atspi_req_version = '>= 2.29.1'
libxml_req_version = '>= 2.9.1'

libdbus_dep = dependency('dbus-1', version: libdbus_req_version)
glib_dep = dependency('glib-2.0', version: glib_req_version)
gobject_dep = dependency('gobject-2.0', version: gobject_req_version)
gmodule_dep = dependency('gmodule-2.0', version: gmodule_req_version)
atk_dep = dependency('atk', version: atk_req_version)
atspi_dep = dependency('atspi-2', version: atspi_req_version)
libxml_dep = dependency('libxml-2.0', version: libxml_req_version, required: false)

if get_option('disable_p2p')
  p2p_cflags = [ '-DDISABLE_P2P' ]
else
  p2p_cflags = []
endif

install_data('at-spi2-atk.desktop',
             install_dir: join_paths(get_option('libdir'), 'gnome-settings-daemon-3.0', 'gtk-modules'))

subdir('droute')
subdir('atk-adaptor')
subdir('tests')