1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103
|
export DH_VERBOSE=1
export DH_OPTIONS
dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS="hardening=+all" DEB_CFLAGS_MAINT_APPEND="-Wall -pedantic -std=gnu89" DEB_LDFLAGS_MAINT_APPEND="-Wl,--as-needed" dpkg-buildflags
configure: configure-stamp
configure-stamp:
dh_testdir
./autogen.sh
dh_auto_configure -- $(shell $(dpkg_buildflags) --export=configure)
touch configure-stamp
build: configure-stamp build-stamp
build-stamp:
dh_testdir
$(MAKE)
touch build-stamp
clean: clean-patched
clean-patched:
dh_testdir
dh_testroot
debconf-updatepo
rm -f build-stamp configure-stamp
[ ! -f Makefile ] || $(MAKE) clean
[ ! -f Makefile ] || $(MAKE) distclean
rm -f compile config.guess config.sub depcomp install-sh missing test-driver
dh_clean
install: DH_OPTIONS=
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
$(MAKE) install prefix=`pwd`/debian/tmp/usr \
mandir=`pwd`/debian/tmp/usr/share/man
dh_movefiles
dh_installdocs -patftp
dh_installdocs -patftpd
binary-indep: build install
binary-arch: DH_OPTIONS=-a
binary-arch: build install
dh_testdir
dh_testroot
dh_installdebconf
dh_installinit
dh_installchangelogs Changelog
dh_strip
dh_link
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
|