File: configure.ac

package info (click to toggle)
atomix 3.22.0-1
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 2,080 kB
  • sloc: xml: 5,958; ansic: 4,611; makefile: 192; sh: 27
file content (63 lines) | stat: -rw-r--r-- 1,358 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
AC_PREREQ([2.63])

AC_INIT([atomix],[3.22.0],[http://bugzilla.gnome.org/enter_bug.cgi?product=atomix])

AX_IS_RELEASE([minor-version])

AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR([src/main.c])
AC_CONFIG_MACRO_DIR([m4])

AM_INIT_AUTOMAKE([1.10 foreign no-dist-gzip dist-xz])

m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])

# Check for programs
AC_PROG_CC
AC_PROG_RANLIB

AM_PROG_AR

AX_REQUIRE_DEFINED([APPSTREAM_XML])
APPSTREAM_XML

AX_COMPILER_FLAGS

dnl ================= Requirements =======================
LIBGTK_REQUIRED=3.10.0
GLIB_REQUIRED=2.36.0
GDK_PIXBUF_REQUIRED=2.0.5

dnl ******************************
dnl pkg-config checks
dnl ******************************

ATOMIX_MODULES="gtk+-3.0 >= $LIBGTK_REQUIRED gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED glib-2.0 >= $GLIB_REQUIRED"
PKG_CHECK_MODULES(ATOMIX, $ATOMIX_MODULES)
AC_SUBST(ATOMIX_CFLAGS)
AC_SUBST(ATOMIX_LIBS)

dnl *******************************
dnl Internationalization
dnl *******************************

IT_PROG_INTLTOOL([0.40.0])

GETTEXT_PACKAGE=atomix
AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE],["$GETTEXT_PACKAGE"],[Gettext domain])
AC_SUBST(GETTEXT_PACKAGE)

AC_CONFIG_FILES([
Makefile
po/Makefile.in
src/Makefile
data/Makefile
data/icons/Makefile
data/icons/hicolor/Makefile
data/themes/Makefile
data/themes/default/Makefile
data/level/Makefile
data/ui/Makefile
])

AC_OUTPUT