1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
DHFLAGS=--parallel
DEB_ATRIL_FLAGS=
ifeq ($(shell dpkg-vendor --is Debian && echo yes),yes)
ifeq ($(shell lsb_release -cs),wheezy)
DEB_ATRIL_FLAGS=--without-keyring
endif
endif
%:
dh $@ $(DHFLAGS) --with gir --without autoreconf
override_dh_missing:
dh_missing --fail-missing
override_dh_install:
rm -rfv debian/tmp/usr/lib/*/*.la
rm -rfv debian/tmp/usr/lib/*/caja/extensions-2.0/*.la
rm -rfv debian/tmp/usr/lib/*/atril/3/backends/*.la
dh_install
override_dh_auto_test:
DEB_BUILD_OPTIONS=nocheck dh_auto_test
override_dh_auto_configure:
NOCONFIGURE=1 ./autogen.sh
dh_auto_configure $(DHFLAGS) -- \
--enable-gtk-doc \
--enable-djvu \
--enable-dvi \
--enable-t1lib \
--enable-pixbuf \
--disable-comics \
--enable-introspection \
--disable-silent-rules \
--disable-static \
--libexecdir=/usr/lib/atril \
$(DEB_ATRIL_FLAGS)
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..
|