File: control

package info (click to toggle)
audit 1:2.8.5-3
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 6,392 kB
  • sloc: ansic: 55,468; sh: 4,848; python: 2,916; makefile: 1,443; sed: 32
file content (134 lines) | stat: -rw-r--r-- 4,801 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
Source: audit
Priority: optional
Maintainer: Laurent Bigonville <bigon@debian.org>
Build-Depends: debhelper-compat (= 12),
               dh-python <!nopython>,
#               dh-golang,
               dpkg-dev (>= 1.16.1~),
               intltool,
               libcap-ng-dev,
# audit sources embed their own patched version of libev
#               libev-dev,
               libkrb5-dev,
               libldap2-dev <!pkg.audit.noldap>,
               libprelude-dev,
               libwrap0-dev,
               python3-all-dev:any <!nopython>,
               libpython3-all-dev <!nopython>,
               swig
Build-Depends-Indep: golang-go
Standards-Version: 4.5.0
Section: libs
Homepage: https://people.redhat.com/sgrubb/audit/
Vcs-Git: https://salsa.debian.org/debian/audit.git
Vcs-Browser: https://salsa.debian.org/debian/audit
Rules-Requires-Root: binary-targets

Package: auditd
Section: admin
Architecture: linux-any
Depends: lsb-base (>= 3.0-6), mawk | gawk, ${misc:Depends}, ${shlibs:Depends}
Suggests: audispd-plugins
Pre-Depends: ${misc:Pre-Depends}
Description: User space tools for security auditing
 The audit package contains the user space utilities for
 storing and searching the audit records generated by
 the audit subsystem in the Linux 2.6 kernel.
 .
 Also contains the audit dispatcher "audisp".

Package: libauparse0
Architecture: linux-any
Pre-Depends: ${misc:Pre-Depends}
Depends: ${misc:Depends}, ${shlibs:Depends}
Breaks: libaudit0, libaudit1 (<< 1:2.2.1-2)
Replaces: libaudit0, libaudit1 (<< 1:2.2.1-2)
Multi-Arch: same
Description: Dynamic library for parsing security auditing
 The libauparse package contains the dynamic libraries needed for
 applications to use the audit framework. It is used to monitor systems for
 security related events.
 .
 This package contains the libauparse0 library.

Package: libauparse-dev
Section: libdevel
Architecture: linux-any
Depends: libauparse0 (= ${binary:Version}), ${misc:Depends}
Breaks: libaudit-dev (<< 1:2.2.1-2)
Replaces: libaudit-dev (<< 1:2.2.1-2)
Multi-arch: same
Description: Header files and static library for the libauparse0 library
 The audit-libs parse package contains the dynamic libraries needed for
 applications to use the audit framework. It is used to monitor systems for
 security related events.

Package: libaudit1
Architecture: linux-any
Pre-Depends: ${misc:Pre-Depends}
Depends: libaudit-common (>= ${source:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Multi-Arch: same
Description: Dynamic library for security auditing
 The audit-libs package contains the dynamic libraries needed for
 applications to use the audit framework. It is used to monitor systems for
 security related events.

Package: libaudit-common
Architecture: all
Depends: ${misc:Depends}
Breaks: libaudit0, libaudit1 (<< 1:2.2.1-2)
Replaces: libaudit0, libaudit1 (<< 1:2.2.1-2)
Multi-Arch: foreign
Description: Dynamic library for security auditing - common files
 The audit-libs package contains the dynamic libraries needed for
 applications to use the audit framework. It is used to monitor systems for
 security related events.
 .
 This package contains the libaudit.conf configuration file and the associated
 manpage.

Package: libaudit-dev
Section: libdevel
Architecture: linux-any
Depends: libaudit1 (= ${binary:Version}), libcap-ng-dev, ${misc:Depends}
Multi-arch: same
Description: Header files and static library for security auditing
 The audit-libs-devel package contains the static libraries and header
 files needed for developing applications that need to use the audit
 framework libraries.

Package: python3-audit
Section: python
Architecture: linux-any
Depends: ${misc:Depends}, ${python3:Depends}, ${shlibs:Depends}
Provides: ${python3:Provides}
Build-Profiles: <!nopython>
Description: Python3 bindings for security auditing
 The package contains the Python3 bindings for libaudit and libauparse, which
 are used to monitor systems for security related events. Python can be used to
 parse and process the security event messages.

Package: golang-redhat-audit-dev
Section: devel
Architecture: all
Depends: ${misc:Depends}
Built-Using: ${misc:Built-Using}
Multi-Arch: foreign
Description: Go client bindings for the libaudit library
 The package contains the Go bindings to libaudit that only allows for logging
 audit events.
 .
 This package contains the source.

Package: audispd-plugins
Section: admin
Architecture: linux-any
Depends: auditd, ${misc:Depends}, ${shlibs:Depends}
Build-Profiles: <!pkg.audit.noldap>
Description: Plugins for the audit event dispatcher
 The audispd-plugins package provides plugins for the real-time
 interface to the audit system, audispd. These plugins can do things
 like relay events to remote machines or analyze events for suspicious
 behavior.