1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62
|
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
%:
dh $@ --with systemd
override_dh_auto_configure:
autoreconf --force
MOUNT=/bin/mount UMOUNT=/bin/umount \
MOUNT_NFS=/sbin/mount.nfs \
E2FSCK=/sbin/fsck.ext2 E3FSCK=/sbin/fsck.ext3 E4FSCK=/sbin/fsck.ext4 \
initdir=/etc/init.d piddir=/var/run \
multiarch=/usr/lib/$(DEB_HOST_MULTIARCH) \
dh_auto_configure -- \
--disable-mount-locking \
--enable-forced-shutdown \
--enable-ignore-busy \
--mandir=/usr/share/man \
--with-confdir=/etc/default \
--with-mapdir=/etc \
--with-fifodir=/var/run --with-flagdir=/var/run \
--with-hesiod \
--with-openldap \
--with-sasl
sed -i 's/.*HAVE_SLOPPY_MOUNT.*/
include/config.h
override_dh_auto_build:
CFLAGS="$(CFLAGS) $(CPPFLAGS)" \
dh_auto_build
override_dh_install:
dh_install
$(RM) debian/autofs/usr/lib/*/autofs/*hesiod*.so \
debian/autofs/usr/lib/*/autofs/*ldap*.so
override_dh_installinit:
dh_installinit -pautofs -- start 19 2 3 4 5 . stop 81 0 1 6 .
override_dh_installchangelogs:
dh_installchangelogs CHANGELOG
override_dh_fixperms:
dh_fixperms -Xdebian/autofs-ldap/etc/autofs_ldap_auth.conf
|