File: changelog

package info (click to toggle)
autopep8 1.5.5-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 1,272 kB
  • sloc: python: 14,130; makefile: 127; sh: 16
file content (224 lines) | stat: -rw-r--r-- 6,826 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
autopep8 (1.5.5-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Update Vcs-* fields with new Debian Python Team Salsa
    layout.

  [ Sandro Tosi ]
  * Use the new Debian Python Team contact name and address

  [ Sylvestre Ledru ]
  * New upstream release

 -- Sylvestre Ledru <sylvestre@debian.org>  Thu, 04 Feb 2021 11:16:29 +0100

autopep8 (1.5.4-1) unstable; urgency=low

  * New upstream release

  [ Debian Janitor ]
  * Bump debhelper from old 10 to 12.
  * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
    Repository-Browse.

 -- Sylvestre Ledru <sylvestre@debian.org>  Mon, 10 Aug 2020 10:35:28 +0200

autopep8 (1.5.3-2) unstable; urgency=medium

  * Upload to unstable

 -- Sylvestre Ledru <sylvestre@debian.org>  Tue, 16 Jun 2020 10:04:40 +0200

autopep8 (1.5.3-1) experimental; urgency=medium

  * New upstream release
    python3-toml is now a build dep

 -- Sylvestre Ledru <sylvestre@debian.org>  Mon, 15 Jun 2020 22:12:58 +0200

autopep8 (1.5.2-1) unstable; urgency=medium

  * New upstream release

 -- Sylvestre Ledru <sylvestre@debian.org>  Sun, 10 May 2020 13:50:35 +0200

autopep8 (1.5.1-1) unstable; urgency=medium

  * New upstream release

 -- Sylvestre Ledru <sylvestre@debian.org>  Sat, 11 Apr 2020 13:03:05 +0200

autopep8 (1.5-1) unstable; urgency=medium

  * New upstream release
  * Update the dependency to pycodestyle the py3 version
    (Closes: #936169)

 -- Sylvestre Ledru <sylvestre@debian.org>  Wed, 22 Jan 2020 14:30:46 +0100

autopep8 (1.4.4-3) unstable; urgency=medium

  * Add missing breaks/replaces (Closes: #945950)

 -- Sylvestre Ledru <sylvestre@debian.org>  Sun, 01 Dec 2019 19:10:50 +0100

autopep8 (1.4.4-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat.
  * d/control: Remove ancient X-Python3-Version field.

  [ Nicholas D Steeves ]
  * Drop bin:python-autopep8, its Build-Depends, and all Python 2
    references in rules. (Closes: #936169)
  * rules: Allow bin:python3-autopep8 to install to /usr/bin.  This
    bin:package now provides /usr/bin/autopep8. (Closes: #909812)
  * Drop Recommends: python-autopep8 from bin:python3-autopep8.
    (Closes: #939051)
  * Drop python3-autopep8.lintian-overrides, which the previous two
    actions make unnecessary.
  * Move python-autopep8.manpages to python3-autopep8.manpages.
  * Switch buildsystem from python_distutils to pybuild.  The package
    FTBFS without this, because of missing X-Python3-Version or
    debian/pyversions, and in the long-term the switch to pybuild is
    probably necessary.  Also, drop the overrides in rules that are
    obsolesced by this action.
  * Add build-dep on dh-sequence-python3.
  * Add python3-lib2to3 as a dependency for bin:python3-autopep8.  I'm not
    sure why it wasn't autodetected, but /usr/bin/autopep8 fails without
    this.

 -- Ondřej Nový <onovy@debian.org>  Sat, 20 Jul 2019 00:35:32 +0200

autopep8 (1.4.4-1) unstable; urgency=medium

  * Upload to unstable

 -- Sylvestre Ledru <sylvestre@debian.org>  Sun, 07 Jul 2019 09:47:05 +0200

autopep8 (1.4.4-1~exp1) experimental; urgency=medium

  * New upstream release

 -- Sylvestre Ledru <sylvestre@debian.org>  Sat, 20 Apr 2019 20:31:52 +0200

autopep8 (1.4.3-1) unstable; urgency=medium

  * New upstream release

 -- Sylvestre Ledru <sylvestre@debian.org>  Thu, 15 Nov 2018 13:59:04 +0100

autopep8 (1.4.2-1) unstable; urgency=medium

  * New upstream release

 -- Sylvestre Ledru <sylvestre@debian.org>  Fri, 26 Oct 2018 09:39:08 +0200

autopep8 (1.4.1-1) unstable; urgency=medium

  * New upstream release

 -- Sylvestre Ledru <sylvestre@debian.org>  Fri, 19 Oct 2018 14:31:09 +0200

autopep8 (1.4-1) unstable; urgency=medium

  * new upstream release
  * Standards-Version: 4.2.1

  [ Ondřej Nový ]
  * d/control: Remove ancient X-Python-Version field

 -- Sylvestre Ledru <sylvestre@debian.org>  Sat, 08 Sep 2018 11:58:59 +0200

autopep8 (1.3.5-2) unstable; urgency=medium

  * Created the new package python3-autopep8. Closes: #875906

 -- Georges Khaznadar <georgesk@debian.org>  Tue, 15 May 2018 18:18:28 +0200

autopep8 (1.3.5-1) unstable; urgency=medium

  * New upstream release

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/copyright: Use https protocol in Format field

 -- Sylvestre Ledru <sylvestre@debian.org>  Sun, 08 Apr 2018 17:46:11 +0200

autopep8 (1.3.4-1) unstable; urgency=medium

  * New upstream release
  * Standards-Version: 4.1.3

 -- Sylvestre Ledru <sylvestre@debian.org>  Thu, 01 Feb 2018 20:31:10 +0100

autopep8 (1.3.3-1) unstable; urgency=medium

  * New upstream release
  * Standards-Version updated to 4.1.1

 -- Sylvestre Ledru <sylvestre@debian.org>  Tue, 24 Oct 2017 15:21:00 +0200

autopep8 (1.3.2-1) unstable; urgency=medium

  * Upload in unstable
  * Standards-Version updated to 4.1.0
  * Make the build reproducible
    Thanks to Chris Lamb for the patch (Closes: #870131

 -- Sylvestre Ledru <sylvestre@debian.org>  Tue, 29 Aug 2017 09:14:17 +0200

autopep8 (1.3.2-1~exp1) experimental; urgency=medium

  * New upstream release (Closes: #806790)
  * Repo moved to git with the NMU (Closes: #848273)
  * Moved to the python team umbrella and me as maintainer
  * Update the min dep of pycodestyle
  * Vcs-Git & Vcs-Browser
  * Standards-Version updated 4.0.0
  * Add a manpage (Closes: #864167)

 -- Sylvestre Ledru <sylvestre@debian.org>  Mon, 19 Jun 2017 22:33:35 +0200

autopep8 (0.9.1-2.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Bumped DH level to 10.
  * debian/control:
      - Added the python-pkg-resources to Depends field. Thanks to
        Sebastian Ramacher. (Closes: #843977)
      - Added the python-pep8 and removed the pep8 from Depends field.
        Thanks to Antonio Ospite and Merlijn van Deen.
        (Closes: #817860, LP: #1635192)
      - Bumped Standards-Version to 3.9.8.
  * debian/copyright: removed a duplicate 'Copyright' word.
  * debian/watch: created.

 -- Daniele Adriana Goulart Lopes <danydrik@yahoo.com.br>  Wed, 14 Dec 2016 16:04:25 -0200

autopep8 (0.9.1-2) unstable; urgency=low

  * Update package short description to be correct (Closes: #711960)
  * Set version depends on pep8 (Closes: #712084)

 -- Micah Anderson <micah@debian.org>  Wed, 12 Jun 2013 16:46:32 -0400

autopep8 (0.9.1-1) unstable; urgency=low

  * Upgrade to new version (Closes: #710681)
  * Fix copyright

 -- Micah Anderson <micah@debian.org>  Tue, 11 Jun 2013 09:11:44 -0400

autopep8 (0.8.7-2) unstable; urgency=low

  * Remove full GPLv3 text from debian/copyright, point to common-licenses

 -- Micah Anderson <micah@debian.org>  Thu, 09 May 2013 15:32:52 -0400

autopep8 (0.8.7-1) unstable; urgency=low

  * Initial package (Closes: #707615)

 -- Micah Anderson <micah@debian.org>  Wed, 08 May 2013 14:35:49 -0400