1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
mkrelease:
quilt push changelog.patch
debian/lib/gen_changelog.sh
dos2unix changelog
quilt refresh
quilt pop -a
@echo
@echo This target is made to fail intentionally, to make sure
@echo that it is NEVER run during the automated build. Please
@echo ignore the following error, the changelog file has been
@echo generated SUCCESSFULLY.
@echo
exit 1
mkman:
go-md2man -in debian/backdoor-factory.1.md -out debian/backdoor-factory.1
@echo
@echo This target is made to fail intentionally, to make sure
@echo that it is NEVER run during the automated build. Please
@echo ignore the following error, the changelog file has been
@echo generated SUCCESSFULLY.
@echo
exit 1
override_dh_install:
dh_install
mv $(CURDIR)/debian/backdoor-factory/usr/bin/backdoor.py $(CURDIR)/debian/backdoor-factory/usr/bin/backdoor-factory
%:
dh $@ --with python3 --buildsystem=pybuild
|