1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57
|
Description: avoid "Old package separator used in string" warnings
Seems with perl 5.38.0 the old package separator (`'`) became
deprecated, causing a warning when found.
Origin: https://github.com/backuppc/backuppc/pull/521
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1065055
From b607ac0c8a82f28db832208842303aca0c356ddc Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andre=20Kl=C3=A4rner?= <kandre@ak-online.be>
Date: Fri, 26 Apr 2024 23:38:57 +0200
Subject: [PATCH] avoid "Old package separator used in string" warnings
Seems with perl 5.38.0 the old package separator (`'`) became
deprecated, causing a warning when found.
bin/BackupPC_backupDelete | 2 +-
bin/BackupPC_backupDuplicate | 2 +-
bin/BackupPC_migrateV3toV4 | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/bin/BackupPC_backupDelete b/bin/BackupPC_backupDelete
index 70577253..f3929d64 100755
@@ -99,7 +99,7 @@ if ( $opts{h} !~ /^([\w\.\s-]+)$/
}
my $Host = $opts{h};
if ( defined(my $error = $bpc->ConfigRead($Host)) ) {
- print(STDERR "BackupPC_backupDelete: Can't read $Host's config file: $error\n");
+ print(STDERR "BackupPC_backupDelete: Can't read ${Host}'s config file: $error\n");
exit(1);
}
%Conf = $bpc->Conf();
diff --git a/bin/BackupPC_backupDuplicate b/bin/BackupPC_backupDuplicate
index d4032a17..c5a2132d 100755
@@ -86,7 +86,7 @@ if ( $opts{h} !~ /^([\w\.\s-]+)$/
}
my $Host = $opts{h};
if ( defined(my $error = $bpc->ConfigRead($Host)) ) {
- print(STDERR "BackupPC_backupDuplicate: Can't read $Host's config file: $error\n");
+ print(STDERR "BackupPC_backupDuplicate: Can't read ${Host}'s config file: $error\n");
exit(1);
}
%Conf = $bpc->Conf();
diff --git a/bin/BackupPC_migrateV3toV4 b/bin/BackupPC_migrateV3toV4
index cb39bb49..24ed0078 100755
@@ -108,7 +108,7 @@ my($Host, $LogLevel, $Compress, $SrcDir, $DestDir, $BkupNum, $Inode, $DeltaInfo,
foreach my $h ( defined($opts{h}) ? ($opts{h}) : sort(keys(%$Hosts)) ) {
$Host = $h;
if ( defined(my $error = $bpc->ConfigRead($Host)) ) {
- print("BackupPC_migrateV3toV4: Can't read $Host's config file: $error\n");
+ print("BackupPC_migrateV3toV4: Can't read ${Host}'s config file: $error\n");
exit(1);
}
#
|