1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
export DH_GOLANG_EXCLUDES := github.com/dgraph-io/badger$
export DH_GOLANG_EXCLUDES_ALL := 0
export DH_GOLANG_INSTALL_EXTRA := fb/gen.sh pb/gen.sh
%:
dh $@ --buildsystem=golang --with=golang
ifeq ($(DEB_HOST_ARCH_BITS),32)
override_dh_auto_test:
-dh_auto_test
endif
ifneq (,$(filter $(DEB_TARGET_ARCH), ppc64el))
ifeq (,$(filter $(DEB_BUILD_OPTIONS), nocheck))
execute_after_dh_auto_test:
echo "Test failure on ppc64el, see https://bugs.debian.org/1078496"
exit 1
endif
endif
override_dh_auto_install:
dh_auto_install
-rm -f debian/tmp/usr/bin/testgc
|