File: README

package info (click to toggle)
banshee-community-extensions 2.4.0-4
  • links: PTS, VCS
  • area: main
  • in suites: jessie-kfreebsd, stretch
  • size: 7,860 kB
  • sloc: cs: 40,928; sh: 11,225; cpp: 1,805; makefile: 1,070; xml: 848; ansic: 450
file content (86 lines) | stat: -rw-r--r-- 1,933 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
Banshee Community Extensions is a repository and project for extensions to the
Banshee media player that are community contributed and maintained.

By bringing various third-party extensions into this one project, we can help
each other maintain them and keep them up to date with the latest Banshee API.

This is meant to be a low-barrier-to-entry way to start, develop, and publish
a Banshee extension.

=======================
Points of Contact
=======================

* Website
  http://banshee-project.org/download/extensions/
  http://banshee-project.org/contribute/write-extensions/

* File bugs
  https://bugzilla.gnome.org/enter_bug.cgi?product=banshee&component=Community%20Extensions

* Mailing list/forum
  http://mail.gnome.org/mailman/listinfo/banshee-list
  http://banshee-project.org/support/forum/

  For BCE maintainers/developers:
  http://mail.gnome.org/mailman/listinfo/banshee-devel-list

* IRC
  #banshee on irc.gnome.org

=======================
Dependencies
=======================

Banshee 2.1.0 and its devel packages are required.  Some extensions have
specific requirements.

AppIndicator
  appindicator-sharp
  notify-sharp

ClutterFlow
  clutter-sharp
  clutter-gtk-sharp

LastfmFingerprint
  glib-2.0
  fftw3f
  samplerate
  gstreamer-1.0 >= 1.0
  gstreamer-base-1.0 >= 1.0
  gstreamer-plugins-base-1.0 >= 1.0

LCD
  LCDProc

Lirc
  LIRC

Mirage:
  glib-2.0
  fftw3f
  samplerate
  gstreamer-1.0 >= 1.0
  gstreamer-base-1.0 >= 1.0
  gstreamer-plugins-base-1.0 >= 1.0

Telepathy
  empathy >= 2.27.91
  telepathy-gabble >= 0.9
  telepathy-mission-control-5 >= 5.3.1
  see src/Telepathy/README for more details

ZeitgeistDataprovider
  zeitgeist-sharp

=======================
Create a New Extension
=======================

Simply run:

./create-extension Foo

Where Foo is the name (with no spaces) of the extension.  Read
http://banshee-project.org/contribute/write-extensions/ for more information.