File: postinst

package info (click to toggle)
bash-completion 1:2.11-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 6,352 kB
  • sloc: python: 8,225; makefile: 1,762; sh: 275; perl: 85; xml: 29; ansic: 7; ruby: 2
file content (34 lines) | stat: -rw-r--r-- 1,000 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
#!/bin/bash

set -e

case "$1" in
    configure)
        if [ -d /etc/bash_completion.d ]; then
            # let's remove old bash-completion conffiles
            for f in $(find /etc/bash_completion.d/ -type f -name "*.dpkg-*"); do
                dpkg-maintscript-helper rm_conffile ${f%.dpkg-*} 1:1.3-1 -- "$@"
            done
        fi

        if dpkg --compare-versions "$2" le "1:2.1-3"; then
            if [ -d /etc/bash_completion.d/helpers ]; then
                rmdir --ignore-fail-on-non-empty /etc/bash_completion.d/helpers 2>/dev/null
            fi
            # disabled from Ubuntu, third party packages might have installed things here
            #if [ -d /etc/bash_completion.d ]; then
            #    rmdir --ignore-fail-on-non-empty /etc/bash_completion.d 2>/dev/null
            #fi
        fi
	;;
    abort-upgrade|abort-remove|abort-deconfigure)
	;;
    *)
        echo "postinst called with unknown argument \`$1'" >&2
        exit 1
    ;;
esac

#DEBHELPER#

exit 0