1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
|
include /usr/share/dpkg/default.mk
ifneq (,$(filter $(DEB_TARGET_ARCH),i386))
export DEB_CFLAGS_MAINT_APPEND += -mfpmath=sse -msse2
endif
%:
dh $@
override_dh_installman:
dh_installman --language=C
clean: config.mk
config.mk:
$(RM) $@ && touch $@
override_dh_autoreconf: config.mk
export MAKEFLAGS="-s"; dh_autoreconf
override_dh_auto_configure:
dh_auto_configure -- \
--with-htslib=system \
--enable-gsl \
--with-cblas=gslcblas \
--with-bcf-plugin-dir=/usr/lib/$(DEB_HOST_MULTIARCH)/bcftools
override_dh_install:
dh_install
for pscript in `grep -Rl '
sed -i '1s?
done
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
make test-no-plugins VERBOSE=1
endif
|