File: changelog

package info (click to toggle)
beets 1.4.9-4
  • links: PTS, VCS
  • area: main
  • in suites: bullseye
  • size: 5,580 kB
  • sloc: python: 37,934; xml: 334; sh: 247; makefile: 117
file content (346 lines) | stat: -rw-r--r-- 12,995 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
beets (1.4.9-4) unstable; urgency=medium

  * Skip a couple more unreliable tests, thanks Santiago Vila
    (Closes: #855092)

 -- Stefano Rivera <stefanor@debian.org>  Fri, 24 Jan 2020 19:16:15 +0200

beets (1.4.9-3) unstable; urgency=medium

  * Patch: mutagen-1.43: Add support for python3-mutagen 1.43 in tests.

 -- Stefano Rivera <stefanor@debian.org>  Fri, 24 Jan 2020 12:13:29 +0200

beets (1.4.9-2) unstable; urgency=medium

  * Patch: skip-buildd-failures: Skip tests failing on the Debian buildds.

 -- Stefano Rivera <stefanor@debian.org>  Wed, 25 Dec 2019 12:47:45 +0200

beets (1.4.9-1) unstable; urgency=medium

  * New upstream release.
  * Refresh patches.
  * Update copyright.
  * Suggest:
    - python3-gi for the bpd and replaygain plugins.
    - python3-pil for the embedart, fetchart, and thumbnails plugins.
    - python3-langdetect for the lyrics plugin.
  * Bump debhelper compat level to 12. As the doc-main-package changed to
    beets:
    - Don't create symlinks to beets-doc from beets, any more.
    - Remove the existing symlink in preinst.
  * Bump Standards-Version to 4.4.1.
  * Remove versioned constraints that pre-date stretch.
  * Run autopkgtests only against the default Python 3. (Closes: #943448)

 -- Stefano Rivera <stefanor@debian.org>  Wed, 25 Dec 2019 08:59:52 +0200

beets (1.4.7-2) unstable; urgency=medium

  * Use py3versions -s in autopkgtests, now that X-Python3-Version is dropped.
    (Closes: #900833, 901716)
  * Patch py37-compat: Cherry pick Python 3.7 support patch from upstream.
    Thanks Michael Hudson-Doyle.
  * Bump Standards-Version to 4.2.0, no changes needed.
  * Skip some tests that seem to commonly fail in builds / autopkgtests, and
    are causing more annoyance than value. This will probably need to be
    extended.

 -- Stefano Rivera <stefanor@debian.org>  Mon, 20 Aug 2018 08:55:31 -0700

beets (1.4.7-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
  * d/control: Remove ancient X-Python3-Version field

  [ Ryan Kavanagh ]
  * Import new upstream version 1.4.7
  * Update copyright file with new authors
  * Bump standards version to 4.1.4
  * Fix packaging to install man pages again.
  * Drop patch update-unidecode-tests, applied upstream

 -- Ryan Kavanagh <rak@debian.org>  Thu, 31 May 2018 10:14:01 -0400

beets (1.4.6-2) unstable; urgency=medium

  [ Stefano Rivera ]
  * Thanks for the NMU, Matthias.
  * Declare Rules-Requires-Root: no.
  * Migrate to git on salsa.debian.org.
  * Simply have the autopkgtests install the build-deps.
  * Patch update-unidecode-tests: unidecode changed behaviour.
  * Bump debhelper compat to 10.
    - Drop dh_compress override, no longer needed.
  * Rely on pybuild for tests and clean.
  * Get the test suite passing (Closes: #892735).
    - Patch no-discogs: discogs is not available in debian.
    - Patch pathlib-is-stdlib: We don't have python3-pathlib in Debian.
    - Patch: skip-broken-test.
  * Drop patch skip-test_query-path-tests, superseded upstream.

  [ Ondřej Nový ]
  * d/copyright: Use https protocol in Format field

 -- Stefano Rivera <stefanor@debian.org>  Mon, 12 Mar 2018 15:20:40 -0700

beets (1.4.6-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Remove Simon Chopin from the uploaders list. Closes: #889761.
  * Run the tests during the build using python3.
  * Run the autopkg tests using python3, update test dependencies.
    Closes: #889078.

 -- Matthias Klose <doko@debian.org>  Mon, 12 Mar 2018 11:44:22 +0100

beets (1.4.6-1) unstable; urgency=medium

  * New upstream release
  * Bump standards version to 4.1.3

 -- Ryan Kavanagh <rak@debian.org>  Thu, 04 Jan 2018 15:51:54 -0500

beets (1.4.5-1) unstable; urgency=medium

  * Team upload
  * New upstream release (Closes: #852257)
    + version number displayed by beets now agrees with the Debian package
      version (Closes: #837193)
    + Fixes issues with broken utf8 filenames (Closes: #851630)

  [ Ryan Kavanagh ]
  * Bumped standards version to 4.0.1
  * Switch to Python 3 now that it's supported by upstream. (Closes: #849085)
    + Update the (build-)dependencies accordingly.
    + Specify that we're using pybuild in the rules
    + Drop (build-)dependencies on python-enum34, python-imaging
      (Closes: #866416), and python-pathlib: these are no longer needed
      with Python 3.
    + We require at least Python 3.4 if we are to drop python-enum34; set
      X-Python3-Version and other dependency versions accordingly.
  * Refreshed patches, and dropped the following unneeded patches:
    fix-test_hidden, fix-test_mediafile_edge, fix-test_nonexistent_file,
    no-jellyfish
  * Because #806716 has been resolved, added a build-dependency on
    python3-jellyfish; this justifies dropping the no-jellyfish patch.
    (Closes: #839640)
  * Fixed insecure URLs for Vcs-Browser; no secure alternative exists for
    Vcs-Svn
  * Updated copyright holders
  * Added myself to the uploaders field
  * Install zsh completion file (Closes: #775811)

 -- Ryan Kavanagh <rak@debian.org>  Mon, 04 Sep 2017 14:26:49 -0400

beets (1.3.19-2) unstable; urgency=medium

  * Fix occasional FTBFS due to lack of mock cleanup. Thanks Santiago Vila.
    (Closes: #835937)
  * Fix autopkgtests by adding the test dependencies, and a sane unittest
    incantation.
  * Drop unittest2 and nose Build-Depends, no longer used.

 -- Stefano Rivera <stefanor@debian.org>  Mon, 29 Aug 2016 22:07:14 -0700

beets (1.3.19-1) unstable; urgency=medium

  * New upstream release. (Closes: #775719, #792060, LP: #1502394)
    - No need to repack any more.
    - Drop patches, superseded upstream.
    - Update copyright.
    - Add Build-Depends: python-{bs4,mpd,mutagen,pathlib,rarfile,xdg}
    - Add Suggests (plugin dependencies):
      python-{dbus,pathlib,rarfile,requests-oauthlib,xdg}
    - Update gstreamer Suggests to python-gst-1.0 (Closes: #785903)
    - Upstream dropped Python 2.6 support.
  * Drop Build-Conflicts: python-rarfile, it seems to be working now.
  * Patches:
    - Bundled a function from jellyfish, pending resolving a package namespace
      problem blocking packaging jellyfish. See #806716.
    - Cherry pick upstream fixes for test_mediafile_edge and test_hidden.
    - Skip tests for path queries, as these are broken by Debian sqlite using
      SQLITE_LIKE_DOESNT_MATCH_BLOBS.
  * Switch watch file to pypi.debian.net. (Closes: #815761)
  * Bump debhelper compat level to 9.
  * Bump Standards-Version to 3.9.8, no changes needed.

 -- Stefano Rivera <stefanor@debian.org>  Tue, 23 Aug 2016 01:18:46 -0700

beets (1.3.8+dfsg-2) unstable; urgency=medium

  * Patch: test_bucket-years. Fix test failure when the current year is >=
    2015 (Closes: #775618)

 -- Stefano Rivera <stefanor@debian.org>  Sun, 18 Jan 2015 11:39:11 -0800

beets (1.3.8+dfsg-1) unstable; urgency=low

  [ Stefano Rivera ]
  * New upstream release. (Closes: #745582)
    - Suggests python-mpd, for mpdstats plugin.
    - Depends on python-enum34, rather than an internal enum implementation.
  * Update (and sort) copyright holders.
  * Suggests python-bs4, for the Lyrics plugin.
  * Repack orig tarball, to remove lyrics with no license for redistribution.

  [ Jackson Doak ]
  * New upstream release. (1.3.3)
    - Build-depend on python-flask
  * Drop no-namespace-pkg patch, fixed upstream

  [ Simon Chopin ]
  * Bump Standards-Version to 3.9.6, no changes needed.
  * Add build-dependencies on python-response and python-nose for the tests
  * Bump copyright year.
  * Add python-pylast to Build-Depends for the tests
  * Patch out the tests depending on pyechonest and rarfile
  * Add new copyright holders for the plugins
  * Build-conflict on python-rarfile as the Debian version don't pass the test
    (note that this is gracefully handled beets)

 -- Simon Chopin <chopin.simon@gmail.com>  Thu, 23 Oct 2014 23:35:11 +0200

beets (1.3.1-1) unstable; urgency=low

  [ Simon Chopin ]
  * Version the dependency on python-musicbrainzngs (>= 0.4) (Closes: #717763)
  * New upstream release (Closes: #730046)
    + Bump the dependency on python-mutagen (>= 1.22)
    + Drop the fix_bpd_search patch, merged upstream.
  * Export PYTHONPATH when building the doc to build the API docs as well.

  [ Stefano Rivera ]
  * Update copyright holders

 -- Simon Chopin <chopin.simon@gmail.com>  Sat, 30 Nov 2013 00:39:48 -0800

beets (1.2.1-1) unstable; urgency=low

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Simon Chopin ]
  * New upstream release (Closes: #715561).
  * Upload to unstable
  * Update watch file to use PyPI.
  * Add a patch to fix a crash in the BPD plugin
  * Update d/copyright with a separate paragraph for beetsplug/* Expat files
  * Add python-requests to the Suggests field for the beatport plugin
  * Add a TODO file to keep track of the unpackaged plugin dependencies

 -- Simon Chopin <chopin.simon@gmail.com>  Mon, 22 Jul 2013 16:12:53 +0200

beets (1.0.0-1) experimental; urgency=low

  * Initial upstream stable release.
  * Bump copyright years.

 -- Stefano Rivera <stefanor@debian.org>  Fri, 08 Feb 2013 14:11:04 +0200

beets (1.0~rc2-1) experimental; urgency=low

  * New upstream release.
  * Update copyright.
  * Support ~rcX in the watch file.
  * Suggest python-imaging for resizing album art (fetchart or embedart
    plugins), and libav-tools for transcoding (convert plugin).
  * Suggest mp3gain for bpd.

 -- Stefano Rivera <stefanor@debian.org>  Sat, 12 Jan 2013 17:21:03 +0200

beets (1.0~b15-1) experimental; urgency=low

  * New upstream release.
    - Album art downloading has been moved into the "fetchart" plugin.
  * Patch no-namespace-pkg: Don't make beetsplug a namespace package, this
    serves no purpose, if we are installing into a private location.
  * Upload to experimental, as Debian is frozen for wheezy.
  * Use the C.UTF-8 locale instead of generating a UTF-8 locale at build time.
    - Build-Depend on libc-bin (>= 2.13).
  * Bump Standards-Version to 3.9.4.
    - Bump debhelpers Build-Depend to 8.1, for build-{arch,indep} support.
  * Add autopkgtests.

 -- Stefano Rivera <stefanor@debian.org>  Tue, 04 Dec 2012 22:39:05 +0200

beets (1.0~b14-2) unstable; urgency=low

  * Split the documentation in a separate beets-doc package (Closes: #672363)
    + Add symlinks in /usr/share/doc/beets to ../beets-doc/

 -- Simon Chopin <chopin.simon@gmail.com>  Sun, 03 Jun 2012 20:29:43 +0200

beets (1.0~b14-1) unstable; urgency=low

  * New upstream release.
    - Update debian/copyright.
  * Respect nocheck in DEB_BUILD_OPTIONS.

 -- Stefano Rivera <stefanor@debian.org>  Sun, 13 May 2012 11:41:35 -0700

beets (1.0~b13-1) unstable; urgency=low

  [ Simon Chopin ]
  * New upstream release.
    - patches unittest2 and integer-timestamps included upstream
  * Add python-pylast to the Suggests: field for the lastgenre plugin.

  [ Stefano Rivera ]
  * Update machine-readable copyright file to Format 1.0.
  * Bump Standards-Version to 3.9.3, no changes needed.

 -- Simon Chopin <chopin.simon@gmail.com>  Wed, 21 Mar 2012 12:30:24 +0200

beets (1.0~b12-1) unstable; urgency=low

  [ Simon Chopin ]
  * New upstream release:
    - Patch libmpd-incompatibility included upstream.
  * Add myself to Uploaders:
  * Add python-musicbrainzngs in Build-Depends: since upstream dropped the embedded
    copy
  * Suggest the python-acoustid package for the chroma plugin
  * Remove the egg-info directory in the clean target of debian/rules to
    enable consecutive builds.

  [ Stefano Rivera ]
  * Refresh patches.
  * Bump copyright years, and add entries for Simon and the replaygain plugin
    from 1.0~b11.
  * Patch: integer-timestamps: Avoid test failure on filesystems with
    high-resolution file timestamps (Closes: #655732)

 -- Simon Chopin <chopin.simon@gmail.com>  Sun, 22 Jan 2012 01:09:03 +0200

beets (1.0~b11-1) unstable; urgency=low

  * New upstream release (Closes: #650078)
    - No need to repack any more, upstream uses non-minified JS.
  * Drop dependency on python-musicbrainz2 (now uses the internal musicbrainz3
    library, soon to be broken out into musicbrainz-ngs).
  * Build docs, they are now included.
    - Use upstream's manpages.
    - Add doc-base entry.
  * Run tests, they are now included.
    - Use unittest2 to provide newer unittest features for python2.6.
    - Build-Depend on python-mutagen, python-munkres, and python-unidecode
    - Test under the en_US.UTF-8 locale, to work around a test expecting a
      UTF-8 locale.
  * Suggest python-rgain, for the rgain plugin.

 -- Stefano Rivera <stefanor@debian.org>  Tue, 13 Dec 2011 16:44:57 +0200

beets (1.0~b10+dfsg-2) unstable; urgency=low

  * Depend on python-pkg-resources (Closes: #649927)

 -- Stefano Rivera <stefanor@debian.org>  Fri, 25 Nov 2011 22:16:27 +0200

beets (1.0~b10+dfsg-1) unstable; urgency=low

  * Initial release (Closes: #589396)

 -- Stefano Rivera <stefanor@debian.org>  Tue, 22 Nov 2011 22:16:28 +0200