1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
export PYBUILD_NAME=betamax
export PYBUILD_TEST_ARGS = --ignore tests/integration/test_fixtures.py \
--ignore tests/integration/test_hooks.py \
--ignore tests/integration/test_placeholders.py \
--ignore tests/integration/test_record_modes.py \
--ignore tests/integration/test_unicode.py \
--ignore tests/regression/test_gzip_compression.py \
--ignore tests/regression/test_requests_2_11_body_matcher.py
%:
dh $@ --with python2,python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_install:
find .pybuild -type f -name test_cassette.test -delete
dh_auto_install
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=. python3 -m sphinx -b html docs/ \
debian/python-betamax-doc/usr/share/doc/python-betamax-doc/html/
dh_sphinxdoc
endif
|