1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22
|
--- a/readcfg.c
+++ b/readcfg.c
@@ -2034,7 +2034,7 @@ static char *describe_addrtype(addrtype
#ifdef BW_LIM
char *describe_rate(long rate)
{
- static char buf[12];
+ static char buf[20];
int c;
if (rate == 0) return "-";
else if (rate < 0) c = sprintf(buf, "%ld%%", -rate);
--- a/client.c
+++ b/client.c
@@ -369,7 +369,7 @@ static int call0 (FTN_NODE *node, BINKD_
if (use_proxy)
{
char *sp, *sport;
- strncpy(host, proxy[0] ? proxy : socks, sizeof(host));
+ strncpy(host, proxy[0] ? proxy : socks, sizeof(host) - 1);
if ((sp=strchr(host, ':')) != NULL)
{
*sp++ = '\0';
|