1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
|
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
export DEB_BUILD_MAINT_OPTIONS = hardening=+all optimize=-lto
include /usr/share/dpkg/default.mk
export XDG_DATA_HOME=/tmp
%:
dh $@ --with pkgkde_symbolshelper
override_dh_missing:
dh_missing --fail-missing
override_dh_auto_configure:
dh_auto_configure -- -DDEB_TARGET_ARCH=$(DEB_TARGET_ARCH) \
-DENABLE_WERROR=OFF \
-DWITH_HYBRIS=OFF \
$(NULL)
override_dh_install:
rm -Rv debian/tmp/etc/init/
rm -v debian/tmp/usr/include/biometry/CMakeLists.txt
dh_install
override_dh_auto_test:
dh_auto_test --no-parallel
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..
|