File: Dependencies.md

package info (click to toggle)
blueman 2.0.4-1~bpo8+1
  • links: PTS
  • area: main
  • in suites: jessie-backports
  • size: 11,368 kB
  • sloc: python: 11,419; sh: 4,270; ansic: 764; makefile: 678; xml: 183
file content (41 lines) | stat: -rw-r--r-- 2,094 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
# Dependencies

## Runtime dependencies

* [BlueZ](http://www.bluez.org/) (>= 4.61)
* [dbus](http://www.freedesktop.org/wiki/Software/dbus/)
* [dbus-python](http://www.freedesktop.org/wiki/Software/DBusBindings/#python)
* [GdkPixbuf](http://www.gtk.org/) (GI bindings)
* [GLib 2, Gio 2](http://www.gtk.org/) (>= 2.32) (GI bindings)
* [GTK+ 3](http://www.gtk.org/) [1] (GI bindings)
* [gnome-icon-theme](https://git.gnome.org/browse/adwaita-icon-theme/) or [mate-icon-theme](https://github.com/mate-desktop/mate-icon-theme)
* [libappindicator](https://launchpad.net/libappindicator) (optional) (GI bindings)
* [notification-daemon](https://git.gnome.org/browse/notification-daemon) or any desktop specific replacement
* [libnotify](https://git.gnome.org/browse/libnotify) (GI bindings)
* [obexd](http://www.bluez.org/) (>= 0.47)
* [Pango](http://www.gtk.org/) (GI bindings)
* [pulseaudio](http://www.freedesktop.org/wiki/Software/PulseAudio/) (optional)
* [pycairo](http://cairographics.org/pycairo/)
* [PyGObject 3](https://wiki.gnome.org/PyGObject)
* [Python](http://www.python.org/) (2.7 or >= 3.2)

## Build dependencies

* [BlueZ](http://www.bluez.org/) (>= 4.61)
* [Cython](http://www.cython.org/)
* [dbus-python](http://www.freedesktop.org/wiki/Software/DBusBindings/#python)
* [GLib 2](http://www.gtk.org/) (>= 2.32)
* [intltool](http://freedesktop.org/wiki/Software/intltool/)
* [libtool](http://www.gnu.org/software/libtool/)
* [PyGObject 3](https://wiki.gnome.org/PyGObject)
* [Python](http://www.python.org/) (2.7 or >= 3.2)

## Additional dependencies for VCS version

* [autogen](https://www.gnu.org/software/autogen/)
* [automake](https://www.gnu.org/software/automake/)
* [autoconf](https://www.gnu.org/software/autoconf/)

[1] There is a known issue with GTK+ <= 3.10.6, possibly in conjuction with specific themes or similar conditions. If it is present and a message is to be displayed in blueman-manager's message area the application will crash with

    Gtk-CRITICAL **: gtk_style_context_get_property: assertion ``priv->widget != NULL || priv->widget_path != NULL' failed