File: changelog

package info (click to toggle)
bmagic 5.0.0-1
  • links: PTS
  • area: main
  • in suites: bullseye, sid
  • size: 41,700 kB
  • sloc: cpp: 71,602; ansic: 8,734; sh: 1,622; makefile: 644
file content (139 lines) | stat: -rw-r--r-- 4,276 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
bmagic (5.0.0-1) unstable; urgency=medium

  * New upstream release (Closes: #872584)
  * Remove Wes Chow as uploader
  * Update to dh compat level 10
  * Drop obsolete patches
  * Update to Standards-Version 4.4.0 (no changes)
  * Mark bmagic binary package as 'Multi-Arch: foreign'
  * Switch build to use CMake
  * Update package copyright information (including upstream change to Apache
    license version 2.0)

 -- Roberto C. Sanchez <roberto@connexer.com>  Tue, 13 Aug 2019 23:51:26 -0400

bmagic (3.7.0-3) unstable; urgency=low

  * Update to Standards-Version 3.9.5 (no changes)

 -- Roberto C. Sanchez <roberto@connexer.com>  Sat, 08 Mar 2014 13:13:36 -0500

bmagic (3.7.0-2) unstable; urgency=low

  [ Marcus Holland-Moritz ]
  * Work around build issues with Clang++ (Closes: #683926)

  [ Roberto C. Sanchez ]
  * Acknowledge NMU, thanks to Matthias Klose
  * Add build-arch and build-indep targets to debian/rules
  * Fix outdated-autotools-helper-file lintian warning
  * Update to Standards-Version 3.9.4 (no changes)

 -- Roberto C. Sanchez <roberto@connexer.com>  Fri, 20 Sep 2013 14:06:19 -0400

bmagic (3.7.0-1.1) unstable; urgency=low

  * Non maintainer upload
  * Work around build failure with GCC 4.7. Closes: #672004.

 -- Matthias Klose <doko@debian.org>  Tue, 22 May 2012 09:07:11 +0000

bmagic (3.7.0-1) unstable; urgency=low

  * New upstream release (Closes: #615929)
  * Update to Standards-Version 3.9.1 (no changes)
  * Specify Debian source format as '3.0 (quilt)'

 -- Roberto C. Sanchez <roberto@connexer.com>  Thu, 03 Mar 2011 12:22:16 -0500

bmagic (3.6.4-1) unstable; urgency=low

  * New upstream release
  * Update to Standards-Version 3.8.4 (no changes)

 -- Roberto C. Sanchez <roberto@connexer.com>  Thu, 08 Apr 2010 16:47:58 -0400

bmagic (3.6.3-1) unstable; urgency=low

  * New upstream release
  * debian/patches/config.guess.patch: drop obsolete patch
  * Add ${misc:Depends} as requested by lintian

 -- Roberto C. Sanchez <roberto@connexer.com>  Sun, 24 Jan 2010 14:45:39 -0500

bmagic (3.6.1-1) unstable; urgency=low

  * New upstream release

 -- Roberto C. Sanchez <roberto@connexer.com>  Wed, 09 Dec 2009 16:02:55 -0500

bmagic (3.6.0-1) unstable; urgency=low

  * New upstream release

 -- Roberto C. Sanchez <roberto@connexer.com>  Fri, 30 Oct 2009 18:48:35 -0400

bmagic (3.5.4-2) unstable; urgency=low

  * Make sample build with g++-4.4

 -- Roberto C. Sanchez <roberto@connexer.com>  Tue, 06 Oct 2009 20:54:02 -0400

bmagic (3.5.4-1) unstable; urgency=low

  * New upstream release
  * Update to Standards-Version 3.8.3 (no changes)
  * Register documentation with doc-base

 -- Roberto C. Sanchez <roberto@connexer.com>  Tue, 29 Sep 2009 20:34:36 -0400

bmagic (3.5.3-1) unstable; urgency=high

  * New upstream release
  * Update to debhelper compatibility level 5
  * Update to Standards-Version 3.8.2 (no changes)
  * Convert from dpatch to quilt
  * Fix FTBFS on amd64, set urgency to high (Closes: #527829)
  * Update copyright
  * Add watch file

 -- Roberto C. Sanchez <roberto@connexer.com>  Wed, 12 Aug 2009 22:01:50 -0400

bmagic (3.5.0-1) unstable; urgency=low

  * New upstream release.
  * Add tcpp.dpatch.  This stops tests/stress/t.cpp from including
    ncbi_pch.hpp.  As far as I can tell, NCBI is not used at all, I have
    no idea where that came from..
  * Silence some lintian warnings; binary-arch-rules-but-pkg-is-arch-indep
    and ancient-standards-version.

 -- Andres Salomon <dilinger@debian.org>  Sat, 05 Jan 2008 23:58:56 +0000

bmagic (3.4.0-4) unstable; urgency=low

  * Fix amd64 patch so that it works correctly with debuild
    cleans. (Closes: #382981)

 -- Wes Chow <wchow@athenacr.com>  Tue, 17 Oct 2006 10:36:56 -0400

bmagic (3.4.0-3) unstable; urgency=low

  * Fix amd64 build problem.  Thanks to Andreas Jochens for the patch.
    (Closes:  #382981)

 -- Wes Chow <wchow@athenacr.com>  Thu, 17 Aug 2006 12:31:54 -0400

bmagic (3.4.0-2) unstable; urgency=low

  * Update maintainer to a company alias, add myself as a maintainer.
  * Change Arch: any to Arch: all.

 -- Andres Salomon <dilinger@debian.org>  Tue, 30 May 2006 23:15:24 +0000

bmagic (3.4.0-1) unstable; urgency=low

  * Initial release.

 -- Wes Chow <wes@senortoad.com>  Wed, 17 May 2006 13:59:28 -0400