1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
|
From: sid <sidtosh4@gmail.com>
Date: Tue, 25 Jun 2024 14:39:08 +0100
Subject: burn-dialog: Use 'media-optical' for notifications
GTK_STOCK_CDROM has been deprecated since GTK 3.10.
Contrary to 'gtk-cdrom', 'media-optical' icon has a symbolic equivalent
'media-optical-symbolic'. So, the notification daemon (e.g. GNOME Shell)
will render the symbolic icon (when available) in notifications, making
it more consistent with rest of GNOME apps.
Bug: https://gitlab.gnome.org/GNOME/brasero/-/issues/347
Origin: upstream, 3.12.4, commit:98342080aa1a05c3543ff45f383681012d4a53c8
libbrasero-burn/brasero-burn-dialog.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libbrasero-burn/brasero-burn-dialog.c b/libbrasero-burn/brasero-burn-dialog.c
index bd1c1da..ae616f3 100644
@@ -157,7 +157,7 @@ brasero_burn_dialog_notify_daemon (BraseroBurnDialog *dialog,
notification = notify_notification_new (message,
NULL,
- GTK_STOCK_CDROM);
+ "media-optical");
if (!notification)
return FALSE;
|