1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37
|
doc_dir=doc/user_manual/
rst_docs=$(wildcard $(addsuffix /*.rst, $(doc_dir)))
html_docs=$(patsubst %.rst, %.html, $(rst_docs))
%:
dh $* --with python3 --buildsystem=pybuild
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
SELFTEST_CONCURRENCY = BRZ_CONCURRENCY=$(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
SELFTEST_PARALLEL = --parallel=fork
else
SELFTEST_CONCURRENCY =
SELFTEST_PARALLEL =
endif
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
$(SELFTEST_CONCURRENCY) BRZ_PLUGINS_AT=debian@$(CURDIR) BRZ_PLUGIN_PATH=-site:-user /usr/bin/brz selftest \
$(SELFTEST_PARALLEL) -v -s bp.debian
endif
%.html: %.rst
rst2html --stylesheet-path=$(doc_dir)/user_manual.css $< > $@
override_dh_auto_build-indep: $(html_docs)
rst2html README.rst > README.html
override_dh_auto_clean:
dh_auto_clean
rm -f $(html_docs)
rm -f README.html
|