1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
EXTRA_CONFIGURE_ARGS = --enable-jack-default-audio --enable-jack-default-midi
ifeq ($(DEB_HOST_ARCH_OS),kfreebsd)
EXTRA_CONFIGURE_ARGS += --disable-alsa
endif
ifeq ($(DEB_HOST_ARCH_OS),hurd)
EXTRA_CONFIGURE_ARGS += --disable-alsa
endif
%:
dh $@ --parallel --with autoreconf
override_dh_auto_configure:
dh_auto_configure -- --prefix=/usr --libdir=\$${prefix}/lib/bristol \
$(EXTRA_CONFIGURE_ARGS)
override_dh_auto_install:
dh_auto_install -- DESTDIR=$(CURDIR)/debian/tmp install
find $(CURDIR)/debian/tmp/usr/share/bristol/ -type d -empty -delete
find $(CURDIR)/debian/tmp/usr/share/ -type f | xargs chmod -x
find $(CURDIR)/debian/tmp/usr/lib/bristol -type f -name '*.la' -delete
override_dh_makeshlibs:
dh_makeshlibs -n
|