1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28
|
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
%:
dh $@ --with ruby --buildsystem cmake
RUBY_VERSION=2.1.0
define newline
endef
override_dh_auto_configure: options+=-DRB_INSTALL_DIR=$(shell $(ruby) -rrbconfig -e 'puts RbConfig::CONFIG["vendorlibdir"]')
override_dh_auto_configure: options+=-DRB_ARCH_INSTALL_DIR=$(shell $(ruby) -rrbconfig -e 'puts RbConfig::CONFIG["vendorarchdir"]')
override_dh_auto_clean \
override_dh_auto_configure \
override_dh_auto_build \
override_dh_auto_test \
override_dh_auto_install:
$(foreach ruby,$(shell find /usr/bin/ -name 'ruby[12]*' | xargs -n1 readlink -f | xargs -n1 basename),\
$(subst override_,,$@) --builddirectory=$(ruby)-obj-$(DEB_HOST_MULTIARCH) -- $(options)$(newline))
|