File: changelog

package info (click to toggle)
buku 4.6%2Bds-1
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, sid
  • size: 1,052 kB
  • sloc: python: 5,997; sh: 92; makefile: 11
file content (214 lines) | stat: -rw-r--r-- 6,120 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
buku (4.6+ds-1) unstable; urgency=medium

  * Import new upstream release

 -- SZ Lin (林上智) <szlin@debian.org>  Fri, 27 Aug 2021 11:29:37 +0800

buku (4.5+ds-1) unstable; urgency=medium

  * Import new upstream release
  * Fix autopkg tests fail with Python 3.9 (Closes: #975539)
  * Bump Standards-Version to 4.5.1
  * The "test_bukuDb.py" unit test is temporarily removed due to a compatible
    issue with current version of pytest (4.6.11-1)

 -- SZ Lin (林上智) <szlin@debian.org>  Thu, 31 Dec 2020 11:05:21 +0800

buku (4.4+ds-1) unstable; urgency=medium

  * Import new upstream release
  * Add Salsa CI configuration file
  * d/control:
    - Bump debhelper-compat to 13

 -- SZ Lin (林上智) <szlin@debian.org>  Tue, 16 Jun 2020 14:51:30 +0800

buku (4.3+ds-1) unstable; urgency=medium

  * Import new upstream release
  * d/control:
    - Bump Standards-Version to 4.5.0

 -- SZ Lin (林上智) <szlin@debian.org>  Sat, 01 Feb 2020 23:00:37 +0800

buku (4.2.2+ds-2) unstable; urgency=low

  * d/control:
    - Bump Standards-Version to 4.4.1
    - Rules-Requires-Root: no
    - Use debhelper-compat (= 12) in build-dependency to replace d/compat
  * d/tests:
    - Add test cases for debci

 -- SZ Lin (林上智) <szlin@debian.org>  Wed, 11 Dec 2019 10:52:16 +0800

buku (4.2.2+ds-1) unstable; urgency=medium

  * Import new upstream release
  * d/watch:
    - Fix malformed filenamemangle

 -- SZ Lin (林上智) <szlin@debian.org>  Thu, 02 May 2019 18:13:59 +0800

buku (4.1+ds-2) unstable; urgency=high

  * Install real program instead of "entry script" (Closes: 920295)

 -- SZ Lin (林上智) <szlin@debian.org>  Fri, 25 Jan 2019 11:13:32 +0800

buku (4.1+ds-1) unstable; urgency=medium

  * Import new upstream release
  * Update d/patches content
  * d/compat:
    - Bump compat version to 12
  * d/control:
    - Bump Standards-Version to 4.3.0
    - Bump debhelper version to 12
  * d/patches:
    - Add "Remove unnecessary copyfile function to avoid upstream changes" patch

 -- SZ Lin (林上智) <szlin@debian.org>  Wed, 16 Jan 2019 22:59:42 +0800

buku (4.0+ds-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Remove ancient X-Python3-Version field

  [ SZ Lin (林上智) ]
  * Import new upstream release
  * Update README.Debian
  * d/control:
    - Tidy long description
    - Add python3-certifi to depends
  * d/copyright:
    - Keep bukuserver removed since the required version of python3-Flask-API
      was not found in Debian archive
  * d/upstream/metadata:
    - Update content
  * d/watch:
    - Update version format to ds since the minified javascript was removed

 -- SZ Lin (林上智) <szlin@debian.org>  Mon, 05 Nov 2018 16:35:02 +0800

buku (3.9+ds-1) unstable; urgency=medium

  * Import new upstream release
  * Add upstream metadata
  * Remove bukuserver via repacking upstream sources since it's WIP in upstream
  * d/control:
    - Bump Standards-Version to 4.2.1

 -- SZ Lin (林上智) <szlin@debian.org>  Sun, 02 Sep 2018 00:12:27 +0800

buku (3.8+dfsg-1) unstable; urgency=medium

  * Import new upstream version
  * Refresh patches after git-dpm to gbp pq conversion
  * Remove bukuserver via repacking upstream sources since it violates DFSG
  * d/control: bump Standards-Version to 4.1.4
  * d/install: Add auto-completion/bash/buku-completion.bash

 -- SZ Lin (林上智) <szlin@debian.org>  Fri, 25 May 2018 17:49:16 +0800

buku (3.7-1) unstable; urgency=medium

  * Import new upstream version
  * d/control: update Vcs to salsa
  *            bump python minimal support version to 3.4
  *            add dh-python into build-dep

 -- SZ Lin (林上智) <szlin@debian.org>  Thu, 29 Mar 2018 09:52:15 +0800

buku (3.6-1) unstable; urgency=medium

  * Import new upstream version
  * d/control: bump Standards-Version to 4.1.3
  * d/control: get rid of requests library dep
  * d/compat: bump compat to 11

 -- SZ Lin (林上智) <szlin@debian.org>  Tue, 09 Jan 2018 23:30:04 +0800

buku (3.5.0-1) unstable; urgency=medium

  * Import new upstream version
  * d/copyright: replace "http" with "https"
  * d/control: bump Standards-Version to 4.1.1
  * Change manpage location

 -- SZ Lin (林上智) <szlin@debian.org>  Fri, 10 Nov 2017 18:03:24 +0800

buku (3.4.0-1) unstable; urgency=medium

  * Import new upstream version

 -- SZ Lin (林上智) <szlin@debian.org>  Mon, 18 Sep 2017 15:28:01 +0800

buku (3.3.1-1) unstable; urgency=medium

  * Import new upstream version
  * Bump Standards-Version to 4.1.0

 -- SZ Lin (林上智) <szlin@debian.org>  Mon, 11 Sep 2017 10:01:10 +0800

buku (3.2.0-1) unstable; urgency=medium

  * Import new upstream version

 -- SZ Lin (林上智) <szlin@debian.org>  Thu, 03 Aug 2017 13:30:31 +0800

buku (3.1.0-1) unstable; urgency=medium

  * Import new upstream version
  * Bump Standards-Version to 4.0.0

 -- SZ Lin (林上智) <szlin@debian.org>  Tue, 11 Jul 2017 10:57:01 +0800

buku (3.0.0-1) unstable; urgency=medium

  * New upstream version

 -- SZ Lin (林上智) <szlin@debian.org>  Sat, 29 Apr 2017 23:00:34 +0800

buku (2.9.0-1) unstable; urgency=medium

  * New upstream version

 -- SZ Lin (林上智) <szlin@debian.org>  Mon, 20 Feb 2017 22:45:20 +0800

buku (2.8.0-1) unstable; urgency=medium

  * New upstream version

 -- SZ Lin (林上智) <szlin@cs.nctu.edu.tw>  Wed, 11 Jan 2017 19:25:38 +0800

buku (2.7.0-1) unstable; urgency=medium

  * New upstream version
  * Add new library dependency

 -- SZ Lin (林上智) <szlin@cs.nctu.edu.tw>  Wed, 30 Nov 2016 14:53:51 +0800

buku (2.6.0-1) unstable; urgency=medium

  * New upstream version

 -- SZ Lin (林上智) <szlin@cs.nctu.edu.tw>  Sat, 05 Nov 2016 15:42:52 +0800

buku (2.5.0-1) unstable; urgency=medium

  * New upstream version

 -- SZ Lin (林上智) <szlin@cs.nctu.edu.tw>  Mon, 24 Oct 2016 19:13:41 +0800

buku (2.4.0-1) unstable; urgency=medium

  * New upstream version

 -- SZ Lin (林上智) <szlin@cs.nctu.edu.tw>  Mon, 12 Sep 2016 13:36:27 +0800

buku (2.3.0-1) unstable; urgency=low

  * Initial release (Closes: #835471)

 -- SZ Lin (林上智) <szlin@cs.nctu.edu.tw>  Fri, 26 Aug 2016 10:36:55 +0800