1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
|
include /usr/share/ocaml/ocamlvars.mk
DESTDIR = $(CURDIR)/debian/tmp
%:
dh $@ --with ocaml --without autoreconf
.PHONY: override_dh_auto_configure
override_dh_auto_configure:
aclocal -I support
autoconf
chmod +x configure
./configure --with-gtk
.PHONY: override_dh_auto_build
override_dh_auto_build:
$(MAKE) all
ifneq ($(OCAML_OPT_ARCH),)
$(MAKE) opt
endif
$(MAKE) doc
.PHONY: override_dh_auto_clean
override_dh_auto_clean:
[ ! -f config.make ] || $(MAKE) clean
$(RM) -f aclocal.m4 config.log config.make config.status configure
$(RM) -rf doc
.PHONY: override_dh_auto_install
override_dh_auto_install:
mkdir -p $(DESTDIR)
$(MAKE) install DESTDIR=$(DESTDIR)
|