File: changelog

package info (click to toggle)
caja-extensions 1.22.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye
  • size: 2,864 kB
  • sloc: ansic: 6,083; makefile: 389; sh: 18
file content (320 lines) | stat: -rw-r--r-- 10,354 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
caja-extensions (1.22.1-2) unstable; urgency=medium

  * debian/control:
    + Bump Standards-Version: to 4.4.1. No changes needed.
    + Add Rules-Requires-Root: field and set it to no.
    + Update B-D. Use gupnp-1.2 on Debian, as well. (Closes: #942343).

 -- Mike Gabriel <sunweaver@debian.org>  Fri, 03 Jan 2020 06:33:18 +0100

caja-extensions (1.22.1-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * New upstream release.

 -- Mike Gabriel <sunweaver@debian.org>  Fri, 27 Sep 2019 19:32:36 +0200

caja-extensions (1.22.0-3) unstable; urgency=medium

  [ Martin Wimpress ]
  * debian/patches:
    + Add 0001_build_with_gupnp10_or_gupnp12.patch. Build either with gupnp
      version 1.0 or 1.2.

 -- Mike Gabriel <sunweaver@debian.org>  Mon, 02 Sep 2019 16:52:03 +0200

caja-extensions (1.22.0-2) unstable; urgency=medium

  [ Martin Wimpress ]
  * debian/control:
    + The libgupnp/libgssdp dev bin:pkgs have been renamed recently.
      So, let's update the B-Ds accordingly by requiring an alternative
      B-D on libgupnp-1.0-dev or libgupnp-1.2-dev. This temporarily
      works around newer libgupnp/libgssdp in Ubuntu (compared to Debian).

 -- Mike Gabriel <sunweaver@debian.org>  Fri, 02 Aug 2019 18:43:42 +0200

caja-extensions (1.22.0-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * New upstream release.
  * debian/control:
    + Updated for MATE Desktop 1.22

  [ Mike Gabriel ]
  * debian/{compat,control}:
    + Use debhelper-compat notation. Bump to DH compat level version 12.
  * debian/control:
    + Bump Standards-Version: to 4.4.0. No changes needed.
  * debian/rules:
    + Drop dbgsym-migration dh_strip override.
  * debian/copyright:
    + Update copyright attributions.

 -- Mike Gabriel <sunweaver@debian.org>  Wed, 31 Jul 2019 16:25:58 +0200

caja-extensions (1.20.2-1) unstable; urgency=medium

  * New upstream release.
  * debian/control:
    + Bump Standards-Version: to 4.3.0. No changes needed.

 -- Mike Gabriel <sunweaver@debian.org>  Fri, 04 Jan 2019 19:25:30 +0100

caja-extensions (1.20.1-1) unstable; urgency=medium

  * New upstream release.
  * debian/patches:
    + Add 1001_pkg-config-macro-not-cross-compilation-safe.patch.
      Simplify PKG_CONFIG presence check.
  * debian/control:
    + Update Vcs-*: fields. Package has been migrated to salsa.debian.org.
    + Bump Standards-Version: to 4.1.4. No changes needed.
    + Drop pkg-mate-team Alioth mailing list from Uploaders: field.
    + White-space fix at EOF.
  * debian/rules:
    + Don't build gtk-doc for sendto extension. Should fix FTCBFS. (Closes:
      #890522).
  * debian/caja-sendto.install:
    + Drop gtk-doc folder.
  * debian/copyright:
    + Use secure URI for copyright format.
    + Fix typo in Upstream-Name: field (and make it more human readable).
    + Update Upstream-Contact: field.
    + Use upstream Git URL in Source: field.
    + Make Upstream-Name: field's value more human readable.
    + Update copyright attributions.
  * debian/upstream/metadata:
    + Add file. Be compliant with DEP-12 proposal.

 -- Mike Gabriel <sunweaver@debian.org>  Thu, 05 Jul 2018 13:24:31 +0200

caja-extensions (1.20.0-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * debian/copyright (already in 1.19.0-0ubuntu1):
    + Update copyright attributions.

  [ Vangelis Mouhtsis ]
  * debian/control (already in 1.19.0-0ubuntu1):
    + Temporarily have pkg-mate-team ML under Uploaders:.
    + Update Maintainer: field to debian-mate ML on lists.debian.org.
    + Rename pretty name of our team -> Debian+Ubuntu MATE Packaging Team.

  [ Mike Gabriel ]
  * debian/patches:
    + Add 1001_pkg-config-macro-not-cross-compilation-safe.patch. Make
      configure.ac cross-compile safe. Thanks to Helmut Grohne for input
      on this.

 -- Mike Gabriel <sunweaver@debian.org>  Wed, 14 Feb 2018 14:36:24 +0100

caja-extensions (1.20.0-0ubuntu1) bionic; urgency=medium

  * New upstream release.

 -- Martin Wimpress <martin.wimpress@ubuntu.com>  Wed, 07 Feb 2018 14:03:56 +0000

caja-extensions (1.19.0-0ubuntu1) bionic; urgency=medium

  * New upstream release.

 -- Martin Wimpress <martin.wimpress@ubuntu.com>  Wed, 24 Jan 2018 00:32:13 +0000

caja-extensions (1.18.2-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * New upstream release.

  [ Mike Gabriel ]
  * Drop caja-gksu bin:package. The gksu utility is deprecated and will be
    removed from Debian soon. (Closes: #822595).
  * debian/control:
    + Typo fix in LONG_DESCRIPTION of bin:package caja-xattr.
  * debian/control:
    + Bump Standards-Version: to 4.1.3. No changes needed.
  * debian/{control,compat}:
    + Bump to DH version level 11.
  * debian/watch:
    + Use secure URL to obtain upstream sources.

 -- Mike Gabriel <sunweaver@debian.org>  Tue, 09 Jan 2018 15:23:02 +0100

caja-extensions (1.18.1-1) unstable; urgency=medium

  [ Aron Xu ]
  * New upstream release.

  [ Martin Wimpress ]
  * debian/control: Dependencies updated for MATE 1.17.
  * debian/rules: Remove obsolete --with-gtk=3.0
  * debian/control: Dependencies updated for MATE 1.18.
  * debian/copyright: Update copyright attributions.
  * debian/control: Add caja-xattr-tags.
  * debian/caja-xattr-tags.install: Add caja-xattr-tags.

  [ Vangelis Mouhtsis ]
  * debian/compat:
    + Update compat version.
  * debian/control:
    + Bump debhelper version to (>= 10.3~).
  * debian/rules:
    + Add new block for override_dh_missing.
  * debian/rules:
    + Disable autoreconf, handled by autogen.sh.

 -- Mike Gabriel <sunweaver@debian.org>  Tue, 25 Jul 2017 19:15:00 +0200

caja-extensions (1.16.0-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * New upstream release.

  [ Vangelis Mouhtsis ]
  * debian/changelog:
    + Fix missing changelog items for 1.15.0-0ubuntu1 upload.
  * debian/control:
    + Dependencies updated for MATE 1.16.
  * debian/watch:
    + Update version matching again to _not_ support development releases.

 -- Mike Gabriel <sunweaver@debian.org>  Tue, 04 Oct 2016 10:35:22 +0200

caja-extensions (1.15.0-0ubuntu1) yakkety; urgency=medium

  * New upstream development release.
  * debian/control:
    + Dependencies updated for MATE 1.15.
  * debian/watch:
    + Update version matching to support development releases.

 -- Martin Wimpress <code@flexion.org>  Fri, 09 Sep 2016 13:04:48 +0100

caja-extensions (1.14.1-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * New upstream release.

  [ Vangelis Mouhtsis ]
  * debian/{control,rules}:
    + dbgsym: Don't build dbg:packages anymore.
      See https://wiki.debian.org/AutomaticDebugPackages.

 -- Mike Gabriel <sunweaver@debian.org>  Mon, 22 Aug 2016 13:11:40 +0200

caja-extensions (1.14.0-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * New upstream release.
  * debian/control:
    + Versioned B-D: libcaja-extension-dev (>= 1.14).
    + B-D: libgtk-3-dev.
    + Versioned B-D: libmate-desktop-dev (>= 1.14).
    + Versioned B-D: mate-common (>= 1.14).
    + Use encrypted URLs for Vcs-*: field.
  * debian/rules:
    + MateConf dropped upstream.
    + Add --with-gtk=3.0
  * debian/copyright:
    + Update copyright attributions.

  [ Mike Gabriel ]
  * debian/control:
    + Bump Standards: to 3.9.8. No changes needed.
    + Versioned B-D on dpkg-dev (>= 1.16.1.1).
  * debian/rules:
    + Enable all hardening flags.
  * lintian: Drop unused override for all bin:pkgs
    (pkg-has-shlibs-control-file-but-no-actual-shared-libs).

 -- Mike Gabriel <sunweaver@debian.org>  Thu, 26 May 2016 05:28:30 +0200

caja-extensions (1.12.0-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * New upstream release.
  * debian/control:
    + Versioned B-D: mate-common (>= 1.12) and libmate-desktop-dev (>= 1.12).

  [ Mike Gabriel ]
  * debian/patches:¬
    + Add 2001_support-icedove-in-caja-sendto.patch. Support "icedove" as¬
      MAILER_THUNDERBIRD variant in caja-sendto plugin. (Closes: #801364).¬
  * lintian:
    + Drop not-used-anymore override postrm-has-useless-call-to-ldconfig for
      all plugin bin:packages.

 -- Mike Gabriel <sunweaver@debian.org>  Sat, 02 Jan 2016 12:20:56 +0100

caja-extensions (1.10.1-1) unstable; urgency=medium

  * New upstream release.

 -- Mike Gabriel <sunweaver@debian.org>  Wed, 02 Sep 2015 06:22:30 +0200

caja-extensions (1.10.0-1) unstable; urgency=medium

  [ Martin Wimpress ]
  * New ustream release.
  * debian/caja-gksu.install:
    + Update for new upstream release.
  * debian/caja-image-converter.install:
    + Update for new upstream release.
  * debian/caja-open-terminal.install:
    + Update for new upstream release.
  * debian/caja-sendto.install:
    + Update for new upstream release.
  * debian/caja-wallpaper.install:
    + Add new package caja-wallpaper.
  * debian/control:
    + Add new package caja-wallpaper.
    + Process with wrap-and-sort.
    + Update descriptions.
  * debian/rules:
    + Add --enable-gtk-doc.
  * debian/watch:
    + Remove +dfsg1 suffix.

  [ Mike Gabriel ]
  * debian/copyright:
    + Update for new upstream release.
  * lintian:
    + Add caja-wallpaper.lintian-overrides. Suppress erroneously triggered
      pkg-has-shlibs-control-file-but-no-actual-shared-libs,
      postinst-has-useless-call-to-ldconfig,
      postrm-has-useless-call-to-ldconfig.

 -- Mike Gabriel <sunweaver@debian.org>  Mon, 24 Aug 2015 17:06:18 +0200

caja-extensions (1.8.0-3) unstable; urgency=medium

  * debian/control:
    + Add to D (caja-gksu): gksu. (Closes: #781951).

 -- Mike Gabriel <sunweaver@debian.org>  Mon, 06 Apr 2015 15:54:52 +0200

caja-extensions (1.8.0-2) unstable; urgency=medium

  [ Mike Gabriel ]
  * lintian: Grammar fix in override reasoning comment.
  * debian/control:
    + Drop from S (caja-sendto): mate-bluetooth. (Not packaged in Debian).
  * debian/rules:
    + Use upstream's NEWS file as upstream ChangeLog.
  * debian/copyright:
    + Really mention all upstream files.
    + Drop information for not-existing-anymore upstream files.

  [ Vangelis Mouhtsis ]
  * debian/rules:
    + Replace on dh_install --list-missing -> --fail-missing
  * debian/control:
    + Bump Standards: to 3.9.6. No changes needed.

 -- Mike Gabriel <sunweaver@debian.org>  Sat, 25 Oct 2014 19:31:47 +0200

caja-extensions (1.8.0-1) unstable; urgency=low

  * Initial release. (Closes: #739374).

 -- Mike Gabriel <sunweaver@debian.org>  Tue, 22 Apr 2014 16:05:25 +0200