1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
ifeq ($(DEB_HOST_ARCH),armel)
export DEB_LDFLAGS_MAINT_APPEND=-latomic
endif
CMAKE_FLAGS = -DCastXML_INSTALL_DOC_DIR:STRING=/usr/share/doc/castxml \
-DLLVM_DIR=/usr/lib/llvm-4.0/cmake
%:
dh $@
override_dh_auto_configure:
dh_auto_configure -- $(CMAKE_FLAGS)
override_dh_installman:
help2man -n "Create an XML representation of C++ declarations" --no-info debian/castxml/usr/bin/castxml > castxml.1
dh_installman castxml.1
|