1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
|
%:
dh $@ --with python3
override_dh_auto_clean:
python3 setup.py clean
rm -f ccsm.desktop ccm/Constants.py ccsm \
ccsm.appdata.xml
dh_auto_clean
override_dh_auto_build:
python3 setup.py build --with-gtk=3.0 --prefix=/usr
override_dh_auto_install:
python3 setup.py install \
--root=debian/compizconfig-settings-manager \
--prefix=/usr $(py_setup_install_args)
override_dh_install:
find $(CURDIR)/debian/compizconfig-settings-manager \
-type f -name '*.pyc' -o -name '*.egg-info' | xargs rm -f
dh_install
|