File: changelog

package info (click to toggle)
cctools 7.0.9-2
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 43,120 kB
  • sloc: ansic: 192,672; cpp: 19,697; perl: 14,056; python: 13,632; sh: 11,008; xml: 3,688; makefile: 1,077; yacc: 433; lex: 151
file content (249 lines) | stat: -rw-r--r-- 8,676 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
cctools (7.0.9-2) unstable; urgency=medium

  * sysmacro.patch: Ensure major/minor macros present on i386. Closes: #917626
  * Standards-Version: 4.3.0

 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 01 Jan 2019 12:15:16 +0000

cctools (7.0.9-1) unstable; urgency=medium

  * New upstream release, closes: #917626
  * Drop hard-coded xz compression
  * Standards-Version: 4.2.1
  * Set BUILD_* in configure for reproducible builds

 -- Alastair McKinstry <mckinstry@debian.org>  Mon, 31 Dec 2018 07:21:13 +0000

cctools (7.0.8-1) unstable; urgency=medium

  * New upstream release
  * Enable verbose build by default for glibc-2.28 transition.
    Closes: #913059
  * perl-path patch: Call 'usr/bin/perl' not 'env perl'

 -- Alastair McKinstry <mckinstry@debian.org>  Thu, 08 Nov 2018 12:09:15 +0000

cctools (7.0.0-1) unstable; urgency=medium

  * New upstream release

 -- Alastair McKinstry <mckinstry@debian.org>  Mon, 09 Jul 2018 09:22:21 +0100

cctools (6.2.10-1) unstable; urgency=medium

  * New upstream release
  * Use xz compression for pkg
  * Add headers to patches
  * Build with support for python3.6, python3.7

 -- Alastair McKinstry <mckinstry@debian.org>  Thu, 28 Jun 2018 15:35:58 +0100

cctools (6.2.9-6) unstable; urgency=medium

  * More work needed on SYS_openat.patch for Arm64 support

 -- Alastair McKinstry <mckinstry@debian.org>  Fri, 15 Jun 2018 09:40:17 +0100

cctools (6.2.9-5) unstable; urgency=medium

  * Fix multiarch triplet detection (use dpkg-printarchitecture)
  * Typo in sys_openat patch

 -- Alastair McKinstry <mckinstry@debian.org>  Thu, 14 Jun 2018 17:02:18 +0100

cctools (6.2.9-4) unstable; urgency=medium

  * Re-enable multiarch_configure patch
  * Remove obsolete patch parrot_run_hang_fix
  * Add 64-bit detection for globus gcc64 flavor

 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 12 Jun 2018 20:03:15 +0100

cctools (6.2.9-3) unstable; urgency=medium

  * Add SYS_openat support for arm64 arch
  * Drop explicit path for --with-mysql-path as it breaks on M-A.

 -- Alastair McKinstry <mckinstry@debian.org>  Mon, 11 Jun 2018 19:56:57 +0100

cctools (6.2.9-2) unstable; urgency=medium

  * Add path for Hurd support

 -- Alastair McKinstry <mckinstry@debian.org>  Sun, 10 Jun 2018 08:44:11 +0100

cctools (6.2.9-1) experimental; urgency=medium

  * New upstream release
  * Refresh patches:
    - remove handle_bashism
    - remove missing_includes
  * Provide python3-workqueue package
  * Update homepage to https version
  * Set coop-computing-tools-doc as M-A: foreign
  * Change VCS paths to salsa.d.o
  * Standards-Version: 4.1.4
  * libperl-dev now needed to build
  * Add new manpages
  * B-D on libsqlite3-dev. Use this rather than embedded copy 

 -- Alastair McKinstry <mckinstry@debian.org>  Tue, 22 May 2018 08:47:14 +0100

cctools (4.0-3) unstable; urgency=medium

  * Adopting cctools. (Closes: #889130)
  * Get mpi path from pkg-config. don't assume /usr/include/mpi/mpi.h
    which breaks on openmpi 

 -- Alastair McKinstry <mckinstry@debian.org>  Mon, 16 Apr 2018 09:12:01 +0100

cctools (4.0-2) unstable; urgency=medium

  * QA upload.
  * Set maintainer to the QA team.
  * Fix FTBFS with glibc 2.26, patch by Juhani Numminen.  (Closes: #887763)
  * Drop debian/patches/multiarch_configure -- upstreamed and unused.
  * Priority optional.

 -- Adam Borowski <kilobyte@angband.pl>  Sat, 03 Feb 2018 04:30:36 +0100

cctools (4.0-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Switch Build-Depends to default-libmysqlclient-dev.  (Closes: #845828)
  * Fix typo in description.  (Closes: #749777)

 -- Andreas Beckmann <anbe@debian.org>  Thu, 12 Jan 2017 17:16:40 +0100

cctools (4.0-1) unstable; urgency=low

  * New upstream release (missed quite a few).
    - Fix FD_CLOEXEC file descriptor flag setting (Closes: #696249).
  * Disabled now obsolete patches (run_tests_on_buildd, parrot_run_hang_fix).
  * Bump debhelper compat level to 9, to enable hardening.
  * Disable API doc generation via doxygen for now -- to avoid delaying this
    overdue upload even longer. The problem of hanging doxygen remains, but is
    now hidden (Closes: #718092).
  * Add patch to use bash as interpreter for ec2_remove_workers -- contains
    bash-specific for loop construct.

 -- Michael Hanke <mih@debian.org>  Mon, 29 Jul 2013 18:55:40 +0200

cctools (3.5.1-2) unstable; urgency=low

  * Apply upstream patch to address parrot_run stalling on Debian wheezy and
    later (Closes: #678417).

 -- Michael Hanke <mih@debian.org>  Sat, 30 Jun 2012 11:35:24 +0200

cctools (3.5.1-1) unstable; urgency=low

  * New upstream bugfix release, adding support for version 3.2 Linux kernels.
  * Temporarily disabling the test suite upon upstream's request, as it
    generates to many false positives.

 -- Michael Hanke <mih@debian.org>  Fri, 29 Jun 2012 08:16:01 +0200

cctools (3.5.0-1) unstable; urgency=low

  * New upstream release.
  * Remove obsolete patches 'missing_cflags' and 'python_compat'. They have
    been merged upstream.
  * Remove DM-upload flag, not needed anymore.
  * Bumped Standards-version to 3.9.3, no changes necessary.
  * Do not install the new 'apps' binaries. They carry language-specific
    filename extensions, and upstream was asked if renaming is possible. Until
    this is decided they won't be installed to avoid changing the API twice.

 -- Michael Hanke <mih@debian.org>  Fri, 15 Jun 2012 08:30:02 +0200

cctools (3.4.2-2) unstable; urgency=low

  * Added patch to handle a missing CFLAGS variable in Python's sysconfig
    report (Closes: #661658).

 -- Michael Hanke <mih@debian.org>  Fri, 30 Mar 2012 12:40:01 +0200

cctools (3.4.2-1) unstable; urgency=low

  * New upstream release.
  * Drop external_python_version patch -- merged upstream.

 -- Michael Hanke <mih@debian.org>  Tue, 21 Feb 2012 16:45:28 +0100

cctools (3.4.0-1) unstable; urgency=low

  * New upstream release.
  * Improve DEP5 compliance of debian/copyright.
  * Added patch to make "starch" use python instead of python2 as interpreter.
  * Tighten build-dependencies (added swig and m4).
  * Enable MPI-support for work-queue.
  * Move to dh_python2.
  * Split Python-bindings for workqueue into a dedicated package and build
    them for all supported Python versions.

 -- Michael Hanke <mih@debian.org>  Wed, 26 Oct 2011 11:51:10 +0200

cctools (3.3.4-2) unstable; urgency=low

  * Added missing build-dependency on ncurses (Closes: #644578).

 -- Michael Hanke <mih@debian.org>  Fri, 07 Oct 2011 14:29:14 +0200

cctools (3.3.4-1) unstable; urgency=low

  * New upstream release.
  * Added patches from upstream SVN with fixes for Debian's multiarch
    (Closes: #635916).
  * Re-enable building parrot on amd64 (broken by fix for kFreeBSD).
  * Enable readline support (added appropriate build-dependencies).

 -- Michael Hanke <mih@debian.org>  Sun, 14 Aug 2011 20:14:30 +0200

cctools (3.3.3-1) unstable; urgency=low

  * New upstream release.
  * Updated Debian configuration patches.
  * Added build-dependency to python-support to install the workqueue
    extension correctly.

 -- Michael Hanke <mih@debian.org>  Thu, 14 Jul 2011 14:41:37 -0400

cctools (3.3.2-4) unstable; urgency=low

  * More FTBFS fixes for kFreeBSD: The netstat API is different from Linux
    platforms. Upstream's tests for a Linux platform actually test for a GNU
    libc, hence "LINUX" is enforced as operating system configure setting to
    keep the patch minimal.
  * Add a dependency on Python to coop-computing-tools. Some tools are
    implemented in Python. Found by lintian.
  * Remove jquery library copy that is included by the latest doxygen.
    Replaced with symlink and package dependency on libjs-jquery.
  * Add DEP-3 compliant headers to all patches.

 -- Michael Hanke <mih@debian.org>  Wed, 11 May 2011 10:32:23 -0400

cctools (3.3.2-3) unstable; urgency=low

  * Fix another FTBFS on kFreeBSD -- assumption that non-Linux is also
    non-GNU.

 -- Michael Hanke <mih@debian.org>  Mon, 09 May 2011 16:40:39 -0400

cctools (3.3.2-2) unstable; urgency=low

  * Fix FTBFS on kFreeBSD -- invalid value in defines (Closes: #626160).
  * Add gridengine-client to suggested packages, as makeflow also supportes
    SGE.
  * Change package long description indentation to be more compatible with
    existing renderers.

 -- Michael Hanke <mih@debian.org>  Mon, 09 May 2011 09:47:37 -0400

cctools (3.3.2-1) unstable; urgency=low

  * Initial release. (Closes: #618774)
  * Named binary package coop-computing-tools to avoid future naming conflict
    with another cctools package, currently in preparation.

 -- Michael Hanke <mih@debian.org>  Sat, 07 May 2011 09:05:00 -0400