File: changelog

package info (click to toggle)
cd-hit 4.8.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 1,940 kB
  • sloc: perl: 7,934; cpp: 3,120; python: 771; makefile: 130; sh: 26; ansic: 6
file content (171 lines) | stat: -rw-r--r-- 5,559 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
cd-hit (4.8.1-2) unstable; urgency=medium

  [ Helmut Grohne ]
  * Fix FTCBFS: Makefile expects a C++ compiler in $CC. (Closes: #932652)

 -- Andreas Tille <tille@debian.org>  Mon, 22 Jul 2019 00:42:22 +0200

cd-hit (4.8.1-1) unstable; urgency=medium

  [ Jelmer Vernooij ]
  * Use secure copyright file specification URI.
  * Trim trailing whitespace.

  [ Andreas Tille ]
  * New upstream version
  * debhelper 12
  * Standards-Version: 4.4.0
  * Remove trailing whitespace in debian/rules
  * Do not parse d/changelog
  * Build-Depends: zlib1g-dev

 -- Andreas Tille <tille@debian.org>  Fri, 19 Jul 2019 19:34:25 +0200

cd-hit (4.6.8-2) unstable; urgency=medium

  * debhelper 11
  * Point Vcs fields to salsa.debian.org
  * Standards-Version: 4.2.1

 -- Andreas Tille <tille@debian.org>  Wed, 19 Sep 2018 14:47:50 +0200

cd-hit (4.6.8-1) unstable; urgency=medium

  * Team upload.
  * New upstream release.
  * Make build reproducible, thanks to Chris Lamb for the patch.
    Closes: #866330

 -- Sascha Steinbiss <satta@debian.org>  Sat, 01 Jul 2017 10:43:07 +0200

cd-hit (4.6.7-1) unstable; urgency=medium

  * New upstream version
    - cd-hit-est and cd-hit-est-2d now can cluster paired end (PE) reads.
    - user can select sub-sequence from the beginning of the sequences for clustering.
    - psi-cd-hit.pl can work with blast+.
    - output cluster file can be sorted by cluster size, in addition to cluster length, which is still the default
    - output fasta file can be sorted by cluster size.
  * upstream/metadata: Added RRID
  * upstream/edam: Crude first entry
  * Team upload.

 -- Steffen Moeller <moeller@debian.org>  Wed, 14 Jun 2017 15:55:31 +0200

cd-hit (4.6.6-2) unstable; urgency=medium

  [ Canberk Koç ]
  * Team upload.
  * Autopkgtest added

  [ Andreas Tille ]
  * Install originally named tools (including '-' to /usr/bin)

 -- Canberk Koç <canberkkoc@gmail.com>  Sun, 14 Aug 2016 14:49:02 +0300

cd-hit (4.6.6-1) unstable; urgency=medium

  * New upstream version
  * Moved from SVN to Git

 -- Andreas Tille <tille@debian.org>  Wed, 03 Aug 2016 22:20:07 +0200

cd-hit (4.6.5-2) unstable; urgency=medium

  * Remove links to scripts that were removed in this version
    Closes: #825582
  * cme fix dpkg-control
  * Better hardening

 -- Andreas Tille <tille@debian.org>  Sat, 28 May 2016 09:24:04 +0200

cd-hit (4.6.5-1) unstable; urgency=medium

  * New upstream version
  * cme fix dpkg-control

 -- Andreas Tille <tille@debian.org>  Wed, 09 Mar 2016 21:47:21 +0100

cd-hit (4.6.4-1) unstable; urgency=medium

  * New upstream version
  * Adapted d/watch to move from google code to Github
  * Remove redundant remark from author about LaTeX source of doc
  * cme fix dpkg-control
  * Update debian/copyright
  * Some tools do not generate a help2man output any more

 -- Andreas Tille <tille@debian.org>  Fri, 22 Jan 2016 15:31:20 +0100

cd-hit (4.6.1-2012-08-27-2) unstable; urgency=low

  * Take over changes from BioLinux

 -- Andreas Tille <tille@debian.org>  Thu, 15 Aug 2013 21:36:49 +0200

cd-hit (4.6.1-2012-08-27-1biolinux1) precise; urgency=low

  * Rebuild for Precice
  * Add new cdhit-454 to /usr/bin, including help2man manpage
  * Remove dependency on openmpi, as cd-hit doesn't use it at all.
    (It uses the -fopenmp compiler flag; maybe there was some confusion?)

 -- Tim Booth <tbooth@ceh.ac.uk>  Thu, 15 Aug 2013 17:00:41 +0100

cd-hit (4.6.1-2012-08-27-1) unstable; urgency=low

  * New upstream version (adapted patches)
  * debian/control:
     - cme fix dpkg-control
     - use anonscm in Vcs fields

 -- Andreas Tille <tille@debian.org>  Sun, 11 Aug 2013 10:51:30 +0200

cd-hit (4.6-2012-04-25-1) unstable; urgency=low

  * New upstream version incorporating the previous patches as
    well as the LaTeX source of the documentation
  * debian/patches/use-dpkg-buildflags.patch: Make sure hardening
    flags will really propagate
  * debian/{control,rules}: Use mpi version of cd-hit
  * README.Debian: Tell users that we are using mpi and they should
    ask for an alternative if needed
  * debian/*.1, debian/manpages: Deleted in favour of autogenerated
    manpages using help2man; Remark: the manually edited pages were
    slightly better regarding "SEE ALSO" and "AUTHORS" sections but
    it is better to auto-generate the pages to stay with changes of
    future versions
  * debian/rules: Use help2man 2 create manpages whereever possible
  * debian/patches/enable_help2man.patch: Fix some minor issues to
    get less error output in man pages

 -- Andreas Tille <tille@debian.org>  Thu, 26 Apr 2012 07:54:23 +0200

cd-hit (4.5.8-2012-03-24-1) unstable; urgency=low

  [ Charles Plessy ]
  * renamed debian/upstream-metadata.yaml to debian/upstream

  [ Andreas Tille ]
  * New upstream version
  * debian/watch: Fixed to reflect the change on code.google.com
  * debian/control: Standards-Version: 3.9.3 (no changes needed)
  * debian/copyright: Fixed DEP5 and verified using
      cme fix dpkg-copyright
  * debian/patches/gcc-4.7.patch: Enable building with g++-4.7
    Closes: #667134
  * debian/upstream:
     - use BibTeX format to specify author
     - Move DOI+PMID to References
     - Differentiate between URl and eprint
  * debhelper 9 (control+compat)

 -- Andreas Tille <tille@debian.org>  Sun, 22 Apr 2012 18:06:41 +0200

cd-hit (4.5.7-1) unstable; urgency=low

  * Initial release (Closes: #652074)
  * This package is recommended by the package qiime and thus it also
    Closes: #651983

 -- Andreas Tille <tille@debian.org>  Wed, 14 Dec 2011 14:39:32 +0100