File: configure.ac

package info (click to toggle)
cdebconf-entropy 0.34
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 636 kB
  • ctags: 109
  • sloc: sh: 2,873; ansic: 882; makefile: 54
file content (50 lines) | stat: -rw-r--r-- 1,427 bytes parent folder | download | duplicates (3)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
AC_INIT

PACKAGE=entropy
AC_DEFINE_UNQUOTED(PACKAGE,"$PACKAGE")

AC_PROG_MAKE_SET
AC_PROG_CC

dnl dh_auto_configure may pass these options, used by some automake macros.
dnl Ignore them.
AC_ARG_ENABLE([maintainer-mode], [])
AC_ARG_ENABLE([dependency-tracking], [])

dnl Enable debugging?
AC_ARG_WITH(debug,[  --without-debug         turn off debugging?])
if test "$with_debug" == "yes"; then
  AC_DEFINE(DODEBUG)
  CFLAGS="$CFLAGS -g -D_DEBUG_"
fi

FRONTENDS="text"

AC_CHECK_LIB([textwrap], [textwrap_init],
        [TEXTWRAP_LIBS="-ltextwrap"
         CPPFLAGS="$CPPFLAGS -DHAVE_LIBTEXTWRAP"])
AC_SUBST([TEXTWRAP_LIBS])

PKG_CHECK_MODULES([NEWT], [libnewt],
                          FRONTENDS="$FRONTENDS newt",
                          echo "*** Cannot build Newt plugin ***")

AC_ARG_WITH([gtk-version], [AS_HELP_STRING([--with-gtk-version],
            [Select version of GTK+ to build for (default 2)])],
            [],
            [with_gtk_version=2])

case $with_gtk_version in
     2)PKG_CHECK_MODULES([GTK], [gtk+-x11-2.0],
                               FRONTENDS="$FRONTENDS gtk",
                               echo "*** Cannot build GTK+ plugin ***");;
     3)PKG_CHECK_MODULES([GTK], [gtk+-x11-3.0],
                               FRONTENDS="$FRONTENDS gtk",
                               echo "*** Cannot build GTK+ plugin ***");;
     *);;
esac

AC_SUBST(FRONTENDS)
AC_SUBST(PACKAGE)

AC_OUTPUT(Makefile)