1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40
|
override_dh_auto_configure:
dh_auto_configure -- \
--libexecdir=/usr/lib \
--with-tmpdir=/var/run/certmonger \
--enable-systemd \
--enable-pie \
--enable-now \
--enable-tmpfiles \
CFLAGS="$(CFLAGS)" \
LDFLAGS="$(LDFLAGS)"
override_dh_auto_install:
dh_auto_install --destdir=debian/tmp
mkdir -p $(CURDIR)/debian/tmp/lib/systemd/system
rm $(CURDIR)/build/systemd/Makefile
cp $(CURDIR)/build/systemd/certmonger.service \
$(CURDIR)/debian/tmp/lib/systemd/system
override_dh_auto_test:
override_dh_install:
dh_install --list-missing
override_dh_clean:
dh_clean
%:
dh $@ --with quilt,autoreconf,systemd --builddirectory=build/
|