File: control

package info (click to toggle)
cg3 1.3.2-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 3,548 kB
  • sloc: cpp: 24,239; xml: 5,615; perl: 1,224; lisp: 876; ansic: 177; sh: 130; php: 104; python: 42; makefile: 16
file content (92 lines) | stat: -rw-r--r-- 2,955 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
Source: cg3
Section: science
Priority: optional
Maintainer: Debian Science Team <debian-science-maintainers@alioth-lists.debian.net>
Uploaders: Tino Didriksen <tino@didriksen.cc>,
           Kartik Mistry <kartik@debian.org>
Build-Depends: cmake,
               debhelper-compat (= 13),
               dh-python,
               libboost-dev,
               libicu-dev,
               python3-dev,
               python3-setuptools,
               swig
Standards-Version: 4.5.1
Homepage: https://visl.sdu.dk/cg3.html
Vcs-Git: https://salsa.debian.org/science-team/cg3.git
Vcs-Browser: https://salsa.debian.org/science-team/cg3
Rules-Requires-Root: no

Package: cg3
Architecture: any
Depends: libcg3-1 (= ${binary:Version}),
         ${misc:Depends},
         ${perl:Depends},
         ${shlibs:Depends}
Provides: vislcg3
Conflicts: vislcg3
Replaces: vislcg3
Suggests: libdigest-sha-perl
Description: Tools for using the 3rd edition of Constraint Grammar (CG-3)
 Constraint Grammar compiler and applicator for the 3rd edition of CG
 that is developed and maintained by VISL SDU and GrammarSoft ApS.
 .
 CG-3 can be used for disambiguation of morphology, syntax, semantics, etc;
 dependency markup, target language lemma choice for MT, QA systems, and
 much more. The core idea is that you choose what to do based on the whole
 available context, as opposed to n-grams.
 .
 See https://visl.sdu.dk/cg3.html for more documentation

Package: cg3-dev
Architecture: all
Depends: cg3 (>= ${binary:Version}),
         libcg3-dev (>= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Description: Metapackage providing both CG-3 CLI dev tools and dev library
 Development files to use the CG-3 CLI tools and library API.
 .
 See https://visl.sdu.dk/cg3.html for more documentation

Package: libcg3-1
Section: libs
Architecture: any
Multi-Arch: same
Pre-Depends: ${misc:Pre-Depends}
Depends: ${misc:Depends}, ${shlibs:Depends}
Provides: libcg3
Conflicts: libcg3
Replaces: libcg3
Description: Runtime for CG-3
 Runtime library for applications using the CG-3 API.
 .
 It is recommended to instrument the CLI tools instead of using this API.
 .
 See https://visl.sdu.dk/cg3.html for more documentation

Package: libcg3-dev
Architecture: any
Multi-Arch: same
Section: libdevel
Pre-Depends: ${misc:Pre-Depends}
Depends: libcg3-1 (= ${binary:Version}), ${misc:Depends}, ${shlibs:Depends}
Description: Headers and shared files to develop using the CG-3 library
 Development files to use the CG-3 API.
 .
 It is recommended to instrument the CLI tools instead of using this API.
 .
 See https://visl.sdu.dk/cg3.html for more documentation

Package: python3-cg3
Architecture: any
Section: python
Provides: ${python3:Provides}
XB-Python-Version: ${python3:Versions}
Depends: libcg3-1 (= ${binary:Version}),
         ${misc:Depends},
         ${python3:Depends},
         ${shlibs:Depends}
Description: Wrapper for CG-3
 Wrapper to use CG-3 from Python