File: INSTALL

package info (click to toggle)
chasen 2.4.5-44
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 2,556 kB
  • sloc: sh: 10,024; ansic: 5,983; cpp: 179; makefile: 111; perl: 10
file content (33 lines) | stat: -rw-r--r-- 1,220 bytes parent folder | download | duplicates (7)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
Installation
---------------

   0.  Install double array library Darts-0.2 or newer version.
       http://cl.aist-nara.ac.jp/~taku-ku/software/darts/
       And Install libiconv if you need.

   1. Type `./configure' to configure the package for your system.
      % ./configure
      You can give `configure' initial values for variables by setting
      them in the environment like this:
      % env CC=gcc CFLAGS="-O2 -Wall" ./configure
      See the file `INSTALL' for detail usage of configure.

   2. Type `make'.
      % make
      This produces the system. You might have to use GNU make.

   3. Type `make install' to install programs.
      # make install
      This will install the following files.
      /usr/local/bin/chasen            ChaSen command
      /usr/local/libexec/chasen/       programs for building dictionaries
      /usr/local/lib/libchasen.*       ChaSen libraries
      /usr/local/include/chasen.h      header files
      /usr/local/share/chasen/doc/     manuals

      The following files will not be installed.
      perl/ChaSen.pm       	       Perl modules to use ChaSen

      To remove old version of ChaSen programs, type the command below.
      # rm -rf /usr/local/lib/chasen